Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516832 - Missing system-release(releasever) for registration client RHEL7.5 to Satellite5
Summary: Missing system-release(releasever) for registration client RHEL7.5 to Satellite5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: redhat-release
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lubos Kocman
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: 1466453
TreeView+ depends on / blocked
 
Reported: 2017-11-23 12:13 UTC by Pavel Studeník
Modified: 2018-04-10 10:21 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 10:20:23 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:0700 None None None 2018-04-10 10:21:18 UTC

Description Pavel Studeník 2017-11-23 12:13:41 UTC
Description of problem:
I tried to register client RHEL 7.5 to Satellite 5. But it not possible because client doesn't send correctly version of release.

RHEL 7.5
# rpm -qa | grep redhat-release
redhat-release-7.5-0.13.el7.x86_64
redhat-release-server-7.5-0.13.el7.x86_64

>>> import sys
>>> sys.path.append("/usr/share/rhn/")
>>> from up2date_client import up2dateUtils
>>> up2dateUtils._getOSVersionAndRelease()
7.5
('redhat-release', '7.5', '0.13.el7')


It is regression. Older RHELs behaves correct.

# rpm -qa | grep redhat-release
redhat-release-server-7.3-7.el7.x86_64

>>> import sys
>>> sys.path.append("/usr/share/rhn/")
>>> from up2date_client import up2dateUtils
>>> up2dateUtils._getOSVersionAndRelease()
('redhat-release-server', '7Server', '7.3-7.el7')


Version-Release number of selected component (if applicable):
redhat-release-7.5-0.13.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. register RH 7.5 to Satellite 5

Actual results:
# rpm -q --provides --whatprovides redhat-release
config(redhat-release) = 7.5-0.13.el7
redhat-release = 7.5-0.13.el7
redhat-release(x86-64) = 7.5-0.13.el7

# rpm -q --provides --whatprovides redhat-release-server
config(redhat-release-server) = 7.5-0.13.el7
redhat-release-server = 7.5-0.13.el7
redhat-release-server(x86-64) = 7.5-0.13.el7
system-release = 7.5-0.13.el7
system-release(releasever) = 7Server
system-release-product = 7.5-0.13.el7


Expected results:
# rpm -q --provides --whatprovides redhat-release
config(redhat-release-server) = 7.3-7.el7
redhat-release = 7.3-7.el7
redhat-release-server = 7.3-7.el7
redhat-release-server(x86-64) = 7.3-7.el7
system-release = 7.3-7.el7
system-release(releasever) = 7Server

# rpm -q --provides --whatprovides redhat-release-server
config(redhat-release-server) = 7.3-7.el7
redhat-release = 7.3-7.el7
redhat-release-server = 7.3-7.el7
redhat-release-server(x86-64) = 7.3-7.el7
system-release = 7.3-7.el7
system-release(releasever) = 7Server

Comment 2 Lubos Kocman 2017-11-24 09:02:31 UTC
Okay, so you pretty much want me to stop providing also system-release = version
I do believe that you guys should really look up just system-release(releasever)

So it could be fixed on both places. But I see no harm in removing the new provide.

Lubos

Comment 3 Lubos Kocman 2017-11-24 14:10:22 UTC
Can you double check on the -14 build?

lkocman@rcm-dev:x86_64> rpm -qpf --provides *
config(redhat-release) = 7.5-0.14.el7
redhat-release = 7.5-0.14.el7
redhat-release = 7.5-0.14.el7
redhat-release(x86-64) = 7.5-0.14.el7
config(redhat-release-client) = 7.5-0.14.el7
system-release = 7.5-0.14.el7
system-release(releasever) = 7Client
system-release-product = 7.5-0.14.el7
redhat-release-client = 7.5-0.14.el7
redhat-release-client(x86-64) = 7.5-0.14.el7
config(redhat-release-computenode) = 7.5-0.14.el7
system-release = 7.5-0.14.el7
system-release(releasever) = 7ComputeNode
system-release-product = 7.5-0.14.el7
redhat-release-computenode = 7.5-0.14.el7
redhat-release-computenode(x86-64) = 7.5-0.14.el7
redhat-release-debuginfo = 7.5-0.14.el7
redhat-release-debuginfo(x86-64) = 7.5-0.14.el7
config(redhat-release-server) = 7.5-0.14.el7
system-release = 7.5-0.14.el7
system-release(releasever) = 7Server
system-release-product = 7.5-0.14.el7
redhat-release-server = 7.5-0.14.el7
redhat-release-server(x86-64) = 7.5-0.14.el7
config(redhat-release-workstation) = 7.5-0.14.el7
system-release = 7.5-0.14.el7
system-release(releasever) = 7Workstation
system-release-product = 7.5-0.14.el7
redhat-release-workstation = 7.5-0.14.el7
redhat-release-workstation(x86-64) = 7.5-0.14.el7
lkocman@rcm-dev:x86_64> rpm -qpf --provides *  | grep releasever
system-release(releasever) = 7Client
system-release(releasever) = 7ComputeNode
system-release(releasever) = 7Server
system-release(releasever) = 7Workstation

Comment 4 Lubos Kocman 2017-11-24 14:10:59 UTC
This version is currently in ET and latest nightly

Comment 5 Pavel Studeník 2017-11-27 13:41:01 UTC
Still doesn't work in redhat-release-7.5-0.14.el7.ppc64le

Current result:
>>> import sys
>>> sys.path.append("/usr/share/rhn/")
>>> from up2date_client import up2dateUtils
>>> up2dateUtils._getOSVersionAndRelease()
('redhat-release', '7.5', '0.14.el7')

>> rpm -q --provides --whatprovides redhat-release
config(redhat-release) = 7.5-0.14.el7
redhat-release = 7.5-0.14.el7
redhat-release(ppc-64) = 7.5-0.14.el7


Expected result for correct registration to Satellite 5: 
...
>>> up2dateUtils._getOSVersionAndRelease()
('redhat-release-server', '7Server', '7.5-0.14.el7')

Comment 9 Lubos Kocman 2017-12-07 12:37:12 UTC
I believe this was fixed by the rollback. Moving to Modified

Comment 10 Pavel Studeník 2017-12-08 09:51:40 UTC
It is fixed for RHEL 7.5 x86_64, s390x

>> rpm -qa | grep release
redhat-release-server-7.5-3.el7.s390x

>> rpm -q --provides --whatprovides redhat-release
config(redhat-release-server) = 7.5-3.el7
redhat-release = 7.5-3.el7
redhat-release-server = 7.5-3.el7
redhat-release-server(s390-64) = 7.5-3.el7
system-release = 7.5-3.el7
system-release(releasever) = 7Server

Comment 14 errata-xmlrpc 2018-04-10 10:20:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:0700


Note You need to log in before you can comment on or make changes to this bug.