Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516829 - Ansible container cannot start in OCP
Summary: Ansible container cannot start in OCP
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: cfme-openshift-embedded-ansible
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: GA
: 5.9.0
Assignee: Nick Carboni
QA Contact: Shalom Naim
URL:
Whiteboard: testathon
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-23 12:12 UTC by Victor Estival
Modified: 2018-07-29 12:33 UTC (History)
11 users (show)

Fixed In Version: cfme-openshift-embedded-ansible:3.1.5-17
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-05 19:42:04 UTC
Category: ---
Cloudforms Team: ---
snaim: automate_bug+


Attachments (Terms of Use)
Log from setup.sh (deleted)
2017-11-23 12:21 UTC, Ramon Gordillo
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0388 normal SHIPPED_LIVE CloudForms 4.6 Ansible for OpenShift bug fix update 2018-03-06 00:40:01 UTC

Description Victor Estival 2017-11-23 12:12:10 UTC
Description of problem:

Ansible container doesn´t even start when activated the role


Version-Release number of selected component (if applicable):
5.9.0.10

How reproducible:
Always

Steps to Reproduce:
1.Deploy CF on OCP
2.Activate embedded Ansible
3.

Actual results:

Ansible container doesn't start and CF stops working

sh-4.2# more setup-2017-11-23-10\:13\:19.log                                                                                                                                                                                              
Using /etc/ansible/ansible.cfg as config file                                                                                                                                                                                             
[DEPRECATION WARNING]: The use of 'include' for tasks has been deprecated. Use                                                                                                                                                            
'import_tasks' for static inclusions or 'include_tasks' for dynamic inclusions.                                                                                                                                                           
 This feature will be removed in a future release. Deprecation warnings can be                                                                                                                                                            
disabled by setting deprecation_warnings=False in ansible.cfg.                                                                                                                                                                            
[DEPRECATION WARNING]: include is kept for backwards compatibility but usage is                                                                                                                                                           
 discouraged. The module documentation details page may explain more about this                                                                                                                                                           
 rationale.. This feature will be removed in a future release. Deprecation                                                                                                                                                                
warnings can be disabled by setting deprecation_warnings=False in ansible.cfg.                                                                                                                                                            
 [WARNING]: Could not match supplied host pattern, ignoring: database                                                                                                                                                                     
                                                                                                                                                                                                                                          
PLAY [tower:database] **********************************************************                                                                                                                                                          
                                                                                                                                                                                                                                          
TASK [check_config_static : Ensure expected variables are defined] *************                                                                                                                                                          
skipping: [localhost] => (item=tower_package_name)  => {"changed": false, "item": "tower_package_name", "skip_reason": "Conditional result was False", "skipped": true}                                                                   
failed: [localhost] (item=tower_package_version) => {"changed": false, "failed": true, "item": "tower_package_version", "msg": "tower_package_version value missing and is required"}                                                     
failed: [localhost] (item=tower_package_release) => {"changed": false, "failed": true, "item": "tower_package_release", "msg": "tower_package_release value missing and is required"}

in

/usr/bin/initialize-tower.sh

ansible-tower-setup -e minimum_var_space=0 -e tower_package_name=ansible-tower-server -i /inventory -- --skip-tags=packages

but in 

/var/lib/awx/setup/roles/check_config_static/test/Makefile

TOWER_VERSION_EXTRAS='-e "tower_package_name=ansible-tower" -e "tower_package_version=2.4.1" -e "tower_package_release=1"'



Expected results:
Embedded Ansible working


Additional info:

Comment 2 Ramon Gordillo 2017-11-23 12:20:36 UTC
When updating initialize-tower.sh with:

ansible-tower-setup -e minimum_var_space=0 -e tower_package_name=ansible-tower -e tower_package_version=2.4.1 -e tower_package_release=1 -i /inventory -- --skip-tags=packages

The playbook continues, but it seems there is an error on rabbitmq reconfiguring. setup.log.

Comment 3 Ramon Gordillo 2017-11-23 12:21:30 UTC
Created attachment 1358175 [details]
Log from setup.sh

Comment 6 juwatts 2018-02-28 21:57:06 UTC
Reopening bug at the request of Dave Johnson

Comment 7 Nick Carboni 2018-02-28 23:57:33 UTC
Looks like we're hitting this https://github.com/rabbitmq/rabbitmq-server/issues/1187

Not sure why we didn't see it before.

Comment 8 Satoe Imaishi 2018-03-01 13:37:36 UTC
PR: https://github.com/ManageIQ/ansible-tower-pods/pull/3

Comment 10 juwatts 2018-03-01 19:55:22 UTC
Ansible container successfully started after activating Embedded Ansible under Configuration

[root@juwatts-ocp-3-6-master cfme46]# oc get pods
NAME                 READY     STATUS    RESTARTS   AGE
ansible-1-pk8bh      1/1       Running   0          9m
cloudforms-0         1/1       Running   0          16m
httpd-1-484nx        1/1       Running   0          16m
memcached-1-cst5x    1/1       Running   0          16m
postgresql-1-2rnzp   1/1       Running   0          16m
[root@juwatts-ocp-3-6-master cfme46]# 

Verified on 5.9.0.22

Comment 13 errata-xmlrpc 2018-03-05 19:42:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0388


Note You need to log in before you can comment on or make changes to this bug.