Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516807 - When no Power Events, TimeLine in SUI resource details shows start date of 1970
Summary: When no Power Events, TimeLine in SUI resource details shows start date of 1970
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - Service
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: GA
: 5.10.0
Assignee: Allen W
QA Contact: Shveta
URL:
Whiteboard: testathon;ssui
Depends On:
Blocks: 1518748
TreeView+ depends on / blocked
 
Reported: 2017-11-23 11:45 UTC by Loic Avenel
Modified: 2018-06-21 20:35 UTC (History)
6 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1518748 (view as bug list)
Environment:
Last Closed: 2018-06-21 20:35:24 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
screenshot (deleted)
2017-11-23 11:45 UTC, Loic Avenel
no flags Details

Description Loic Avenel 2017-11-23 11:45:58 UTC
Created attachment 1358167 [details]
screenshot

Description of problem: When no Power Events, TimeLine in SUI resource details shows start date of 1970


Version-Release number of selected component (if applicable): 5.9.0.10.20171121225911_a2209d2


How reproducible:


Steps to Reproduce:
1. deploy a virtual Machines and don't start it.
2. go to SUI and view resource details
3.

Actual results: TimeLine Start from 1970


Expected results: start from last 7 days


Additional info:

Comment 2 Dave Johnson 2017-11-23 12:02:44 UTC
Please assess the impact of this issue and update the severity accordingly.  Please refer to https://bugzilla.redhat.com/page.cgi?id=fields.html#bug_severity for a reminder on each severity's definition.

If it's something like a tracker bug where it doesn't matter, please set the severity to Low.

Comment 3 Allen W 2017-11-28 18:52:26 UTC
Ok I know we marked this as low, but gonna wrap up a few other minor bug things into this pr, looks like compliance icon is wrong, and for utilization, there can sometimes be used data overflow. pr inc

Comment 4 Loic Avenel 2017-11-28 21:11:54 UTC
(In reply to Allen W from comment #3)
> Ok I know we marked this as low, but gonna wrap up a few other minor bug
> things into this pr, looks like compliance icon is wrong, and for
> utilization, there can sometimes be used data overflow. pr inc

Perfect

Comment 5 Allen W 2017-11-28 22:53:40 UTC
https://github.com/ManageIQ/manageiq-ui-service/pull/1284

Ok here we go, its out there, picture in the pr of the things that changed, the tldr is: 

* timeline, when empty shows 7 day range
* compliance icon is now correct, value is capitalized 
* utilization data now grabs the hour behind the latest (where as before it was grabbing the second item in an array)
* utilization available number has been truncated to three positions


Note You need to log in before you can comment on or make changes to this bug.