Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516793 - Can't Manage Report Menu Accordions
Summary: Can't Manage Report Menu Accordions
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Reporting
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.10.0
Assignee: Nick Carboni
QA Contact: Niyaz Akhtar Ansari
URL:
Whiteboard: testathon
: 1518930 (view as bug list)
Depends On:
Blocks: 1489837 1519858
TreeView+ depends on / blocked
 
Reported: 2017-11-23 11:34 UTC by Niyaz Akhtar Ansari
Modified: 2018-06-21 20:37 UTC (History)
8 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1519858 (view as bug list)
Environment:
Last Closed: 2018-06-21 20:37:48 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)

Description Niyaz Akhtar Ansari 2017-11-23 11:34:39 UTC
Description of problem:


Version-Release number of selected component (if applicable):
Version 5.9.0.9.20171115202245_7429f75

How reproducible:
100%

Steps to Reproduce:
1.Go to Edit Reports Menus accordion
2.Select EvmGroup-super_administrator
3.Add/Edit menu folder(Move selected folder to top, Add folder to selected folder)

Actual results:
Unable to Manage Report Menu Accordions

Expected results:
It should work

Additional info:
Demo Link: https://goo.gl/mMPuxk

Comment 2 Gregg Tanzillo 2017-11-24 13:23:08 UTC
Dan, please reassign to appliance if this is a backend issue.

Comment 4 Niyaz Akhtar Ansari 2017-11-30 09:10:56 UTC
*** Bug 1518930 has been marked as a duplicate of this bug. ***

Comment 6 CFME Bot 2017-12-01 11:56:41 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/57c8d632b54d4d6d31789473dd35d2106e4e1c71

commit 57c8d632b54d4d6d31789473dd35d2106e4e1c71
Author:     Nick Carboni <ncarboni@redhat.com>
AuthorDate: Thu Nov 30 16:11:38 2017 -0500
Commit:     Nick Carboni <ncarboni@redhat.com>
CommitDate: Thu Nov 30 17:03:26 2017 -0500

    Redefine MiqGroup #settings and #settings=
    
    This commit ensures that #settings returns the same object that
    exists in the object.
    
    This ensures that calls like the following will work as expected:
    
    group.settings[:a] = 1
    
    Previously, #settings returned the duplicate object created by
    Hash#with_indifferent_access
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1516793

 app/models/miq_group.rb | 11 ++++++++++-
 1 file changed, 10 insertions(+), 1 deletion(-)

Comment 7 CFME Bot 2017-12-01 11:56:46 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/66f86e4798307998fc98cc2e0de8c04a06cf61e8

commit 66f86e4798307998fc98cc2e0de8c04a06cf61e8
Author:     Nick Carboni <ncarboni@redhat.com>
AuthorDate: Thu Nov 30 16:10:15 2017 -0500
Commit:     Nick Carboni <ncarboni@redhat.com>
CommitDate: Thu Nov 30 17:03:26 2017 -0500

    Add spec to ensure MiqGroup#settings doesn't return a duplicate object
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1516793

 spec/models/miq_group_spec.rb | 15 +++++++++++++++
 1 file changed, 15 insertions(+)


Note You need to log in before you can comment on or make changes to this bug.