Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516784 - Unresponsive button 'Download PDF' on Dashboard
Summary: Unresponsive button 'Download PDF' on Dashboard
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.10.0
Assignee: Martin Hradil
QA Contact: Dmitry Misharov
URL:
Whiteboard: testathon
Depends On:
Blocks: 1519840
TreeView+ depends on / blocked
 
Reported: 2017-11-23 11:27 UTC by Vatsal Parekh
Modified: 2018-06-21 21:18 UTC (History)
6 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1519840 (view as bug list)
Environment:
Last Closed: 2018-06-21 21:18:31 UTC
Category: Bug
Cloudforms Team: CFME Core


Attachments (Terms of Use)

Description Vatsal Parekh 2017-11-23 11:27:45 UTC
Description of problem:
The button of 'Download PDF' on almost all widgets on dashboard are unresponsive, it doesn't do anything.

Version-Release number of selected component (if applicable):
Version 5.9.0.9.20171115202245_7429f75

How reproducible:


Steps to Reproduce:
1.Dashboard->Download PDF on widget
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Milan Zázrivec 2017-11-30 08:14:56 UTC

*** This bug has been marked as a duplicate of bug 1516839 ***

Comment 4 Milan Zázrivec 2017-11-30 16:15:52 UTC
Actually, this is not a duplicate. Reopening.

Comment 6 CFME Bot 2017-12-01 09:33:45 UTC
New commit detected on ManageIQ/manageiq-ui-classic/master:
https://github.com/ManageIQ/manageiq-ui-classic/commit/cd2d8ef36181325972d208d1a8ae06e4c0fa9669

commit cd2d8ef36181325972d208d1a8ae06e4c0fa9669
Author:     Martin Hradil <mhradil@redhat.com>
AuthorDate: Thu Nov 30 16:20:32 2017 +0000
Commit:     Martin Hradil <mhradil@redhat.com>
CommitDate: Thu Nov 30 16:22:30 2017 +0000

    dropdownMenu - don't use data-remote when not provided
    
    When the link has `data-remote=""`, downloading a PDF doesn't work. (The request succeeds, the data is returned, but the browser ignores it and doesn't download.)
    
    `data-remote` is used for other things, like minimizing the dashboard.
    
    Thus, changing to use `ng-attr-data-remote`, which will do the same thing as before when the attribute value is provided, but won't add the attr when empty.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1516784

 app/views/static/dropdown-menu.html.haml | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)


Note You need to log in before you can comment on or make changes to this bug.