Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516773 - openstack overcloud update does not preserve roles_data.yaml
Summary: openstack overcloud update does not preserve roles_data.yaml
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ga
: 12.0 (Pike)
Assignee: mathieu bultel
QA Contact: Yurii Prokulevych
URL:
Whiteboard:
: 1516456 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-23 11:20 UTC by Lukas Bezdicka
Modified: 2018-08-22 04:20 UTC (History)
12 users (show)

Fixed In Version: openstack-tripleo-common-7.6.3-8.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-13 22:22:16 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 522657 None master: MERGED tripleo-common: Add exclude list to not override user data (I4e53d8f95170c25b32a6d714a7620c2c9d2596f3) 2017-11-28 21:58:31 UTC
OpenStack gerrit 523398 None stable/pike: NEW tripleo-common: Add exclude list to not override user data (I4e53d8f95170c25b32a6d714a7620c2c9d2596f3) 2017-11-28 21:58:27 UTC
Launchpad 1734108 None None None 2017-11-23 11:26:26 UTC
Red Hat Product Errata RHEA-2017:3462 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Description Lukas Bezdicka 2017-11-23 11:20:02 UTC
When running update --init-minor-update command the user provided roles_data.yaml gets overwritten thus breaking the environment completly.

Comment 2 Lukas Bezdicka 2017-11-23 11:41:23 UTC
*** Bug 1516456 has been marked as a duplicate of this bug. ***

Comment 8 Yurii Prokulevych 2017-12-12 14:38:58 UTC
Verified with openstack-tripleo-common-7.6.3-8.el7ost.noarch

Comment 11 errata-xmlrpc 2017-12-13 22:22:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.