Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516758 - [ALL_LANG except en_US] Exception thrown while opening version info page
Summary: [ALL_LANG except en_US] Exception thrown while opening version info page
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: ---
Hardware: All
OS: Linux
medium
high vote
Target Milestone: ovirt-4.2.0
: 4.2.0
Assignee: bugs@ovirt.org
QA Contact: Pavel Stehlik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-23 11:10 UTC by Bhushan Barve
Modified: 2018-05-14 16:35 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-12 12:57:38 UTC
oVirt Team: UX
rule-engine: ovirt-4.2+
gshereme: devel_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:1488 normal SHIPPED_LIVE Red Hat Virtualization Manager (ovirt-engine) 4.2 GA 2018-06-07 17:27:12 UTC

Description Bhushan Barve 2017-11-23 11:10:26 UTC
Description of problem: For all locales other than English, when user tries to view version info by clicking on 'help' menu button at the top, following exception gets thrown -

Unbehandelter Fehler. Bitte versuchen Sie die Seite erneut zu laden. Details: Exception caught: Number of place holders does not match number of arguments
Wenden Sie sich an Ihren Systemadministrator, damit dieser die UI-Protokolle überprüft

Here is the translation from google translate-

Untreated error. Please try reloading the page. Details: Exception caught: Number of place holders does not match numbers of arguments
Contact your system administrator to check the UI logs

Not able to view the version info screen for any locale.



Version-Release number of selected component (if applicable):
RHV 4.2.0-0.4


How reproducible:
always


Steps to Reproduce:
1. Login to RHV 4.2 admin portal with any locale other then English.
2. click on help option at the top
3. under that, click on Version information.

Actual results:
Exception is thrown. User unable to view version info.

Expected results:
Version info screen should get displayed.

Additional info:
Work fine for English locale.

Comment 1 Greg Sheremeta 2017-11-27 19:30:28 UTC
I made some changes to this About dialog since 4.2.0-4, and I cannot duplicate using any locale. In addition, I checked the strings, and I don't see any mismatched placeholders. So I think this will work in the latest build.

Please re-test on 4.2.0-7. Thanks :)

Comment 4 RHV Bugzilla Automation and Verification Bot 2017-12-06 16:15:54 UTC
INFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[No external trackers attached]

For more info please contact: rhv-devops@redhat.com

Comment 5 RHV Bugzilla Automation and Verification Bot 2017-12-12 21:14:29 UTC
INFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[No external trackers attached]

For more info please contact: rhv-devops@redhat.com

Comment 6 RHV Bugzilla Automation and Verification Bot 2017-12-18 17:04:54 UTC
INFO: Bug status (ON_QA) wasn't changed but the folowing should be fixed:

[No external trackers attached]

For more info please contact: rhv-devops@redhat.com

Comment 7 Greg Sheremeta 2017-12-30 13:52:06 UTC
@QE, please retest and close

Comment 8 Greg Sheremeta 2017-12-30 13:54:26 UTC
@QE, please retest and close

Comment 9 Bhushan Barve 2018-01-02 07:08:01 UTC
Checked with 4.2.0.2-0.1.el7
Works fine now for all locales. 
Marking it as verified.


Note You need to log in before you can comment on or make changes to this bug.