Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516747 - yum localupdate python-libipa_hbac show Protected multilib versions: libipa_hbac-1.13.3-22.el6_8.6.x86_64 != libipa_hbac-1.12.4-47.el6_7.8.i686
Summary: yum localupdate python-libipa_hbac show Protected multilib versions: libipa_h...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum
Version: 6.5
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Valentina Mukhamedzhanova
QA Contact: BaseOS QE Security Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-23 11:01 UTC by Zeng Yiquan
Modified: 2017-11-28 16:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-28 16:35:29 UTC


Attachments (Terms of Use)

Description Zeng Yiquan 2017-11-23 11:01:20 UTC
Description of problem:

When we use command as reproduce steps, there error message will be output.

Version-Release number of selected component (if applicable):

RHEL6.5 

How reproducible:

Steps to Reproduce:
1. yum --releasever=6.8 update python-libipa_hbac --downloadonly --downloaddir=/root/Test_Patch/
2. cd /root/Test_Patch/
3. yum localupdate ./*.rpm

Actual results:
===
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:
       
         1. You have an upgrade for libipa_hbac which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of libipa_hbac of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude libipa_hbac.otherarch ... this should give you an error
            message showing the root cause of the problem.
       
         2. You have multiple architectures of libipa_hbac installed, but
            yum can only see an upgrade for one of those arcitectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.
       
         3. You have duplicate versions of libipa_hbac installed already.
            You can use "yum check" to get yum show these errors.
       
       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).
       
       Protected multilib versions: libipa_hbac-1.13.3-22.el6_8.6.x86_64 != libipa_hbac-1.12.4-47.el6_7.8.i686
[root@R65 Test_Patch]# 

Expected results:

Update the downloded python-libipa_hbac package normally.

Additional info:

No matter whether the current system have installed the python-libipa_hbac package or not.


Note You need to log in before you can comment on or make changes to this bug.