Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516715 - [abrt] octave: octave::my_friendly_exit(char const*, int, bool)(): octave-gui killed by SIGABRT
Summary: [abrt] octave: octave::my_friendly_exit(char const*, int, bool)(): octave-gui...
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Fedora
Classification: Fedora
Component: octave
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:7ab12c487c6260063a64da4b4a9...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-23 10:14 UTC by mithrial
Modified: 2018-03-28 04:06 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-28 04:06:58 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2017-11-23 10:14 UTC, mithrial
no flags Details
File: cgroup (deleted)
2017-11-23 10:14 UTC, mithrial
no flags Details
File: core_backtrace (deleted)
2017-11-23 10:14 UTC, mithrial
no flags Details
File: cpuinfo (deleted)
2017-11-23 10:14 UTC, mithrial
no flags Details
File: dso_list (deleted)
2017-11-23 10:14 UTC, mithrial
no flags Details
File: environ (deleted)
2017-11-23 10:14 UTC, mithrial
no flags Details
File: limits (deleted)
2017-11-23 10:14 UTC, mithrial
no flags Details
File: maps (deleted)
2017-11-23 10:14 UTC, mithrial
no flags Details
File: mountinfo (deleted)
2017-11-23 10:14 UTC, mithrial
no flags Details
File: open_fds (deleted)
2017-11-23 10:14 UTC, mithrial
no flags Details
File: proc_pid_status (deleted)
2017-11-23 10:14 UTC, mithrial
no flags Details

Description mithrial 2017-11-23 10:14:22 UTC
Description of problem:
I closed the program.

Version-Release number of selected component:
octave-4.2.1-4.fc27.2

Additional info:
reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        /usr/libexec/octave/4.2.1/exec/x86_64-redhat-linux-gnu/octave-gui
crash_function: octave::my_friendly_exit(char const*, int, bool)
executable:     /usr/libexec/octave/4.2.1/exec/x86_64-redhat-linux-gnu/octave-gui
journald_cursor: s=ce86e915be9a48cc85f791a1e1d3f294;i=bf4d;b=08b2c89df3b34d98a626f7978c7f5a41;m=11a9fa497b;t=55ea2d3388a60;x=53d5624f9bd19346
kernel:         4.13.13-300.fc27.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (1 frames)
 #2 octave::my_friendly_exit(char const*, int, bool) at libinterp/corefcn/sighandlers.cc:378

Comment 1 mithrial 2017-11-23 10:14:31 UTC
Created attachment 1358117 [details]
File: backtrace

Comment 2 mithrial 2017-11-23 10:14:33 UTC
Created attachment 1358118 [details]
File: cgroup

Comment 3 mithrial 2017-11-23 10:14:35 UTC
Created attachment 1358119 [details]
File: core_backtrace

Comment 4 mithrial 2017-11-23 10:14:37 UTC
Created attachment 1358120 [details]
File: cpuinfo

Comment 5 mithrial 2017-11-23 10:14:39 UTC
Created attachment 1358121 [details]
File: dso_list

Comment 6 mithrial 2017-11-23 10:14:40 UTC
Created attachment 1358122 [details]
File: environ

Comment 7 mithrial 2017-11-23 10:14:42 UTC
Created attachment 1358123 [details]
File: limits

Comment 8 mithrial 2017-11-23 10:14:44 UTC
Created attachment 1358124 [details]
File: maps

Comment 9 mithrial 2017-11-23 10:14:46 UTC
Created attachment 1358125 [details]
File: mountinfo

Comment 10 mithrial 2017-11-23 10:14:48 UTC
Created attachment 1358126 [details]
File: open_fds

Comment 11 mithrial 2017-11-23 10:14:49 UTC
Created attachment 1358127 [details]
File: proc_pid_status

Comment 12 jakob.jakobson18 2017-11-28 12:05:17 UTC
*** Bug 1518205 has been marked as a duplicate of this bug. ***

Comment 13 Lorenzo Zanetti 2017-12-13 18:02:47 UTC
Similar problem has been detected:

Quitting octave is enough: no actions other than typing "exit" at the prompt is required.
The location from which octave is launched is irrelevant.
The usage of GUI or the command line interface is irrelevant (it always happens).
I tried to compile from source and the issue persisted (identical: signal 6 on exit).
I think this issue appeared shortly after glibc was uptadet to 2.26 --it was still Fedora 26.

reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        /usr/libexec/octave/4.2.1/exec/x86_64-redhat-linux-gnu/octave-gui --no-gui
crash_function: octave::my_friendly_exit(char const*, int, bool)
executable:     /usr/libexec/octave/4.2.1/exec/x86_64-redhat-linux-gnu/octave-gui
journald_cursor: s=6366e7f7b8194e78adf8ed729882cb57;i=219c0a;b=09b9606e85434d42b3dfd7b988c6b7ca;m=32cf6aefa;t=5603c5beedbff;x=d5421feb487d6e2
kernel:         4.15.0-rc3
package:        octave-4.2.1-4.fc27.2
reason:         octave-gui killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 14 mithrial 2018-01-05 16:53:18 UTC
Similar problem has been detected:

I opened the program, typed 'exit' to close it again. Nothing inbetween.

reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        /usr/libexec/octave/4.2.1/exec/x86_64-redhat-linux-gnu/octave-gui
crash_function: octave::my_friendly_exit(char const*, int, bool)
executable:     /usr/libexec/octave/4.2.1/exec/x86_64-redhat-linux-gnu/octave-gui
journald_cursor: s=ce86e915be9a48cc85f791a1e1d3f294;i=2e4e8;b=dda53a95e09e4ac7bbcdf2e57ac5dbe5;m=7374ab669;t=5620a0b99d401;x=9409dc51b6184711
kernel:         4.14.11-300.fc27.x86_64
package:        octave-4.2.1-4.fc27.2
reason:         octave-gui killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 15 Keefer Rourke 2018-01-18 22:03:11 UTC
Similar problem has been detected:

Octave crashed upon opening a downloaded MATLAB file from Firefox.

Octave also appears to crash upon opening a MATLAB file from Nautilus.

reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        /usr/libexec/octave/4.2.1/exec/x86_64-redhat-linux-gnu/octave-gui --force-gui /home/spooky/NextCloud/cloud.krourke.org/Documents/W18/MATH2130/Labs/Lab02/soln/horner.m
crash_function: octave::my_friendly_exit(char const*, int, bool)
executable:     /usr/libexec/octave/4.2.1/exec/x86_64-redhat-linux-gnu/octave-gui
journald_cursor: s=f29fe70d675f4fa9a148734ef5da775a;i=94095;b=58206ccf69eb44cd8d6479ce3c7c9051;m=23faa1d71e;t=56312f16c8466;x=85e2ea984f2ab025
kernel:         4.14.13-300.fc27.x86_64
package:        octave-4.2.1-4.fc27.2
reason:         octave-gui killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 16 ALI-S0 2018-02-20 09:27:49 UTC
Similar problem has been detected:

I opened the program, typed 'quit' to close it again. Nothing in between.
and again i opened the program, typed 'exit' to close it again,
and the problem also happened.

cmdline: /usr/libexec/octave/4.2.1/exec/x86_64-redhat-linux-gnu/octave-gui --force-gui
crash_function: octave::my_friendly_exit(char const*, int, bool)
executable: /usr/libexec/octave/4.2.1/exec/x86_64-redhat-linux-gnu/octave-gui
kernel: 4.15.3-300.fc27.x86_64
package: octave-4.2.1-4.fc27.2
reason: octave-gui killed by SIGABRT
rootdir: /
type: CCpp

Comment 17 Colin Macdonald 2018-03-28 04:06:58 UTC

*** This bug has been marked as a duplicate of bug 1504304 ***


Note You need to log in before you can comment on or make changes to this bug.