Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516710 - Container Topology download button thorws "undefined method `authentications' for nil:NilClass [ems_container/download_summary_pdf]"
Summary: Container Topology download button thorws "undefined method `authentications'...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: GA
: 5.10.0
Assignee: Dávid Halász
QA Contact: Dave Johnson
URL:
Whiteboard: testathon
: 1518226 (view as bug list)
Depends On:
Blocks: 1520531
TreeView+ depends on / blocked
 
Reported: 2017-11-23 10:09 UTC by Satyajit Bulage
Modified: 2018-06-21 20:31 UTC (History)
8 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1520531 (view as bug list)
Environment:
Last Closed: 2018-06-21 20:31:14 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot showing actual results (deleted)
2017-11-23 10:09 UTC, Satyajit Bulage
no flags Details

Description Satyajit Bulage 2017-11-23 10:09:27 UTC
Created attachment 1358113 [details]
Screenshot showing actual results

Description of problem:


Version-Release number of selected component (if applicable):5.9.0.10.20171121225911_a2209d2


How reproducible:100%


Steps to Reproduce:
1. Navigate to Compute --> Containers
2. Click on Topology view
3. Click on Download button

Actual results: Unexpected error in UI


Expected results: PDF should be downloaded without any error.


Additional info:

Comment 10 Dávid Halász 2017-11-30 08:52:09 UTC
*** Bug 1518226 has been marked as a duplicate of this bug. ***

Comment 11 CFME Bot 2017-12-04 14:04:13 UTC
New commit detected on ManageIQ/manageiq-ui-classic/master:
https://github.com/ManageIQ/manageiq-ui-classic/commit/a6f3450d59edb98b16876e30d8b8b52b90092806

commit a6f3450d59edb98b16876e30d8b8b52b90092806
Author:     Dávid Halász <dhalasz@redhat.com>
AuthorDate: Fri Nov 24 16:27:09 2017 +0100
Commit:     Dávid Halász <dhalasz@redhat.com>
CommitDate: Thu Nov 30 17:44:04 2017 +0100

    Use record instead of ems instance var in textual authentication status
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1516710

 app/helpers/textual_mixins/textual_authentications_status.rb | 4 ++--
 app/helpers/textual_mixins/textual_metrics_status.rb         | 8 ++++----
 2 files changed, 6 insertions(+), 6 deletions(-)


Note You need to log in before you can comment on or make changes to this bug.