Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516672 - Volume deleted but still shows up on the Grafana dashboard (With a white background)
Summary: Volume deleted but still shows up on the Grafana dashboard (With a white back...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-ui
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: gowtham
QA Contact: Filip Balák
URL:
Whiteboard:
: 1513414 1517435 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-23 09:05 UTC by Rochelle
Modified: 2018-06-11 11:06 UTC (History)
8 users (show)

Fixed In Version: tendrl-ui-1.5.4-4.el7rhgs.noarch tendrl-monitoring-integration-1.5.4-8.el7rhgs.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-18 04:37:58 UTC


Attachments (Terms of Use)
Volume deleted but still shows up on the Grafana dashboard (With a white background) (deleted)
2017-11-23 09:05 UTC, Rochelle
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3478 normal SHIPPED_LIVE RHGS Web Administration packages 2017-12-18 09:34:49 UTC
Red Hat Bugzilla 1589765 None CLOSED Volume deleted but still shows up on the Grafana dashboard 2019-02-27 09:08:08 UTC

Internal Links: 1589765

Description Rochelle 2017-11-23 09:05:45 UTC
Created attachment 1358075 [details]
Volume deleted but still shows up on the Grafana dashboard (With a white background)

Description of problem:
=======================
A volume was deleted from the imported cluster but still shows up on the Grafana dashboard which could be misleading. 

Under 'Tendrl-Gluster-at-a-Glance' under Top Consumers and Status there are 3 volumes shown but under volumes, 2 volumes are correctly shown.

volume1 and volume2 are the only volumes on the cluster but volume3 still shows up on the Grafana dashbaord which can be seen in the image attached.

[root@dhcp42-110 ~]# gluster v info
 
Volume Name: volume1
Type: Distributed-Replicate
Volume ID: 857a7433-b359-4bb4-8a06-7ed43c613279
Status: Started
Snapshot Count: 0
Number of Bricks: 2 x 3 = 6
Transport-type: tcp
Bricks:
Brick1: dhcp42-110.lab.eng.blr.redhat.com:/bricks/brick0/b1
Brick2: dhcp42-136.lab.eng.blr.redhat.com:/bricks/brick0/b2
Brick3: dhcp42-2.lab.eng.blr.redhat.com:/bricks/brick0/b3
Brick4: dhcp42-110.lab.eng.blr.redhat.com:/bricks/brick1/b4
Brick5: dhcp42-136.lab.eng.blr.redhat.com:/bricks/brick1/b5
Brick6: dhcp42-2.lab.eng.blr.redhat.com:/bricks/brick1/b6
Options Reconfigured:
diagnostics.count-fop-hits: on
diagnostics.latency-measurement: on
transport.address-family: inet
nfs.disable: on
 
Volume Name: volume2
Type: Distributed-Replicate
Volume ID: efe05337-b08b-4d13-bac6-f0dd6fbfb458
Status: Started
Snapshot Count: 0
Number of Bricks: 2 x 3 = 6
Transport-type: tcp
Bricks:
Brick1: dhcp42-110.lab.eng.blr.redhat.com:/bricks/brick2/b1
Brick2: dhcp42-136.lab.eng.blr.redhat.com:/bricks/brick2/b2
Brick3: dhcp42-2.lab.eng.blr.redhat.com:/bricks/brick2/b3
Brick4: dhcp42-110.lab.eng.blr.redhat.com:/bricks/brick2/b4
Brick5: dhcp42-136.lab.eng.blr.redhat.com:/bricks/brick2/b5
Brick6: dhcp42-2.lab.eng.blr.redhat.com:/bricks/brick2/b6
Options Reconfigured:
diagnostics.count-fop-hits: on
diagnostics.latency-measurement: on
transport.address-family: inet
nfs.disable: on
[root@dhcp42-110 ~]# 


Version-Release number of selected component (if applicable):
============================================================
tendrl-ui-1.5.4-4.el7rhgs.noarch



Actual results:
==============
The volume that has been deleted still shows up in the 'Tendrl-Gluster-At-a-Glance' page under top consumers and status

Expected results:
================
Deleted volumes should not be mentioned.


Additional info:

Comment 3 Martin Kudlej 2017-11-23 20:47:04 UTC
*** Bug 1513414 has been marked as a duplicate of this bug. ***

Comment 4 Martin Kudlej 2017-11-27 06:54:46 UTC
*** Bug 1517435 has been marked as a duplicate of this bug. ***

Comment 5 Petr Penicka 2017-11-27 18:27:07 UTC
Giving PM ack and including in 3.3.1.

Comment 7 Filip Balák 2017-11-28 17:34:56 UTC
Looks ok. -> VERIFIED

Tested with:
tendrl-gluster-integration-1.5.4-6.el7rhgs.noarch
tendrl-node-agent-1.5.4-8.el7rhgs.noarch
tendrl-notifier-1.5.4-5.el7rhgs.noarch
tendrl-selinux-1.5.4-1.el7rhgs.noarch
tendrl-commons-1.5.4-5.el7rhgs.noarch
tendrl-api-1.5.4-3.el7rhgs.noarch
tendrl-api-httpd-1.5.4-3.el7rhgs.noarch
tendrl-monitoring-integration-1.5.4-8.el7rhgs.noarch
tendrl-grafana-selinux-1.5.4-1.el7rhgs.noarch
tendrl-ansible-1.5.4-2.el7rhgs.noarch
tendrl-ui-1.5.4-4.el7rhgs.noarch
tendrl-grafana-plugins-1.5.4-8.el7rhgs.noarch

Comment 9 errata-xmlrpc 2017-12-18 04:37:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3478


Note You need to log in before you can comment on or make changes to this bug.