Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516668 - Multiple notification in SSUI
Summary: Multiple notification in SSUI
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - Service
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: GA
: cfme-future
Assignee: Allen W
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On: 1527053
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-23 09:00 UTC by Vatsal Parekh
Modified: 2019-02-19 15:01 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-19 13:26:18 UTC
Category: Bug
Cloudforms Team: CFME Core


Attachments (Terms of Use)
screenshot (deleted)
2017-11-23 09:00 UTC, Vatsal Parekh
no flags Details

Description Vatsal Parekh 2017-11-23 09:00:25 UTC
Created attachment 1358073 [details]
screenshot

Description of problem:
Ordering a catalog from SSUI, that failed to provision, gave multiple notifications
Check the attached screenshot

Version-Release number of selected component (if applicable):
Version: 5.9.0.9.20171115202245_7429f75

How reproducible:


Steps to Reproduce:
1.Order a catalog
2.If it failed, gives multiple notification
3.

Actual results:
Unnecessary multiple notification 

Expected results:
Should give only one failure notification

Additional info:

Comment 2 Allen W 2017-12-07 16:48:12 UTC
Woah, so this is tricky, been noticed before, check-it, we already had work to solve this issue done here: https://github.com/ManageIQ/manageiq-ui-service/pull/751

need confirmation the resolution agreed upon here: https://github.com/ManageIQ/manageiq-ui-service/pull/751#issuecomment-308491121 still stands (as the request to close the pr ultimately stopped this from getting this merged)

Comment 3 Allen W 2017-12-07 21:36:35 UTC
ok so this us up there, lets see what happens

https://github.com/ManageIQ/manageiq-ui-service/pull/1328

Comment 4 Ohad Levy 2017-12-14 12:39:39 UTC
I would not assume this is a blocker, this simply show the error message multiple times?

Comment 5 Chris Pelland 2017-12-14 16:44:33 UTC
Vatsal, Please provide logs as this will help engineering troubleshoot.

Comment 6 Vatsal Parekh 2017-12-18 12:47:53 UTC
Cannot test this due to this https://bugzilla.redhat.com/show_bug.cgi?id=1527053

Comment 7 Allen W 2018-01-08 16:13:28 UTC
Said bug has been moved to post, but there is still much discussion on how to resolve this.


Note You need to log in before you can comment on or make changes to this bug.