Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516639 - [RHV] VM provisioned from pxe fail to boot post installation
Summary: [RHV] VM provisioned from pxe fail to boot post installation
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: GA
: cfme-future
Assignee: Oved Ourfali
QA Contact: Ilanit Stein
URL:
Whiteboard: rhev:pxe provisioning
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-23 07:38 UTC by Ilanit Stein
Modified: 2017-12-05 15:25 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-26 06:50:43 UTC
Category: Bug
Cloudforms Team: RHEVM


Attachments (Terms of Use)
rhel7.4_customize_template (deleted)
2017-11-23 07:39 UTC, Ilanit Stein
no flags Details
provisioned_VM_boot_failure.png (deleted)
2017-11-23 07:39 UTC, Ilanit Stein
no flags Details

Description Ilanit Stein 2017-11-23 07:38:43 UTC
Description of problem:
Provision VM from PXE, with a rhel7.4 image from pxe server,
In the provision dialog customize tab:
a rhel7.4 customized template was selected (attached "rhel7.4_customize_ template"), and in addition a root password was inserted in upper side of this dialog window. 

The result was the same for both CFME-5.7.4.1 & CFME-5.8.2.3:

The rhel7.4 was installed, then after post installation stage, 
the VM was rebooted, however after reboot, 
VM failed to load from the hard disk on: Error: No configuration file found 
(attached screen shot of the VM console)

On CFME side, the provision request ended up successfully,
since it was waiting for VM power off, and that stage did take place.


Version-Release number of selected component (if applicable):
CFME-5.8.2.3, CFME-5.7.4.1/RHV-4.1.7

How reproducible:
100%

Expected results:
1. VM installed from PXE should boot successfully, after installation.
2. ON CFME side, the VM provision request should not end up successfully, in such case,
of VM failing to boot after installation & reboot.

Comment 2 Ilanit Stein 2017-11-23 07:39:13 UTC
Created attachment 1358053 [details]
rhel7.4_customize_template

Comment 3 Ilanit Stein 2017-11-23 07:39:54 UTC
Created attachment 1358054 [details]
provisioned_VM_boot_failure.png

Comment 5 Ilanit Stein 2017-11-23 14:26:05 UTC
After investigating the issue, along with dpinhas from eng-ops,
He found the problem was with the CFME customize template (the kickstart file we use, for the installation)

He changed the bootloader settings, ans that resolved the issue:

bootloader --timeout=3 --extlinux => 
bootloader --location=mbr --append="rhgb quiet"

Now the VM provisioned from pxe, with the rhel7.4, along with the customize template kickstart is installed & then boots the OS just fine.

Oved,
Can we resolve the expected result 2., mentioned in the description?

Comment 6 Oved Ourfali 2017-11-23 14:28:27 UTC
We can't.
As far as we're concerned it was booted correctly.

Comment 7 Ilanit Stein 2017-11-26 06:50:43 UTC
Closing the bug, as the root cause was wrong bootloder in the kickstart file.


Note You need to log in before you can comment on or make changes to this bug.