Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516557 - Set disable:true for oci-machine-register
Summary: Set disable:true for oci-machine-register
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-tripleo
Version: 12.0 (Pike)
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: rc
: 12.0 (Pike)
Assignee: RHOS Maint
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-22 22:32 UTC by Angus Thomas
Modified: 2018-02-05 19:18 UTC (History)
10 users (show)

Fixed In Version: puppet-tripleo-7.4.3-9.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-13 22:22:16 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3462 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Description Angus Thomas 2017-11-22 22:32:35 UTC
As described here ( https://bugzilla.redhat.com/show_bug.cgi?id=1514511 ) there is an issue here systemd would stop the docker service incorrectly. Often seeming to occur when a container was in a restart state.

A patch has been merged to address this: https://code.engineering.redhat.com/gerrit/#/c/124023/

Comment 4 Chris Jones 2017-11-27 16:01:38 UTC
@Omri: I believe that as well as a hard reboot, you also need a container that's failing and being restarted, to properly trigger this issue.

Comment 5 Omri Hochman 2017-11-29 18:54:08 UTC
Verified with puppet-tripleo-7.4.3-10.el7ost.noarch


unable to reproduce the race issue by running overcloud reboot loop while one of the containers is in "Restarting" status . 

steps:
(1)  caused horizon container to be stuck in 'restarting status' 
[root@overcloud-controller-1 ~]# docker ps | grep horizon
6047011009b6        192.168.0.1:8787/rhosp12/openstack-horizon-docker:12.0-20171128.1                   "kolla_start"            29 minutes ago      Restarting (2) About a min
               horizon

(changed the docker start command pointing to different ports ) 
  
(2)  ran "Killer Reboot test case" -  5 X  reboot , wait 5 minutes sleep after each reboot.

results : docker is still up and running on the OC nodes. while the horizon container is still stuck in restarting.

Comment 8 errata-xmlrpc 2017-12-13 22:22:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.