Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516552 - RFE: Introduce novacontrol role in tripleo-heat-templates
Summary: RFE: Introduce novacontrol role in tripleo-heat-templates
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 12.0 (Pike)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: Upstream M3
: 13.0 (Queens)
Assignee: Lee Yarwood
QA Contact: Gabriel Szasz
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-22 22:15 UTC by Archit Modi
Modified: 2018-06-27 13:40 UTC (History)
7 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.0-0.20180304031144.6cd4184.el7.centos
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:39:31 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:40:23 UTC
OpenStack gerrit 526501 None master: MERGED tripleo-heat-templates: Add Novacontrol role (Ib973765343dc1bf97b95c8aea3234916fa7a519a) 2018-02-28 13:44:42 UTC

Description Archit Modi 2017-11-22 22:15:29 UTC
Description of problem: novacontrol.yaml is missing in https://github.com/openstack/tripleo-heat-templates/tree/master/roles


Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-7.0.3-9.el7ost.noarch

How reproducible: Always


Steps to Reproduce:
1. Deploy RHOS-12 with 1 undercloud, 1 compute, 1 controller and 1 novacontrol
2. Generate openstack roles with the above mentioned topology

Actual results:
[stack@undercloud-0 roles]$ openstack overcloud roles generate -o /home/stack/composable_roles/roles/roles_data.yaml \
>     Novacontrol \
>     Controller \
>     Compute \
> 
Invalid roles requested: Novacontrol
Valid Roles:
BlockStorage
CephStorage
Compute
ComputeHCI
ComputeOvsDpdk
Controller
ControllerOpenstack
Database
IronicConductor
Messaging
Networker
ObjectStorage
Telemetry
Undercloud
UndercloudLight


Expected results: Deploment runs successfully


Additional info:

Comment 1 Emilien Macchi 2017-11-23 02:55:50 UTC
I'm not sure what is Novacontrol (probably a custom role that you created) but not something that exists upstream, hence, I'm not sure about the bug. Feel free to re-open if you have more details about the actual problem. I think your roles_data is wrong and doesn't contain your custom role.

Comment 3 Marius Cornea 2017-11-23 16:04:36 UTC
(In reply to Emilien Macchi from comment #1)
> I'm not sure what is Novacontrol (probably a custom role that you created)
> but not something that exists upstream, hence, I'm not sure about the bug.
> Feel free to re-open if you have more details about the actual problem. I
> think your roles_data is wrong and doesn't contain your custom role.

I believe Novacontrol is the standalone role hosting the Nova control plane services(the 'Nova' role as advertised in the supported custom roles by the product docs[1]). THT doesn't provide such predefined role but it is required for testing. Given that we want to use the new way of generating roles_data starting with OSP12  and not build the roles_data manually then we need this role to be available in $THT/roles.

[1] https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/11/html-single/advanced_overcloud_customization/#Standalone-Nova

Comment 4 Lee Yarwood 2017-11-30 16:09:01 UTC
Opening this back up as a Compute DFG RFE to track the novacontrol role into THT and ensure it is tested ahead of the OSP 13 release.

Comment 11 errata-xmlrpc 2018-06-27 13:39:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.