Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516494 - VDSM command GetVmsInfoVDS failed: Missing OVF file from VM
Summary: VDSM command GetVmsInfoVDS failed: Missing OVF file from VM
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage
Version: 4.1.6.2
Hardware: x86_64
OS: Linux
unspecified
high vote
Target Milestone: ovirt-4.1.9
: ---
Assignee: Benny Zlotnik
QA Contact: Yosi Ben Shimon
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-22 18:21 UTC by Aleksey
Modified: 2018-01-29 01:38 UTC (History)
5 users (show)

Fixed In Version: ovirt-engine-4.1.9
Doc Type: Known Issue
Doc Text:
Previously, having an empty VM directory in the export domain caused an error when trying to read the VMs stored in it, resulting in endless SPM re-elections. Now, this issue no longer causes SPM re-election. To fix the VM list loading error, you must remove the empty directory manually.
Clone Of:
Environment:
Last Closed: 2018-01-24 10:40:30 UTC
oVirt Team: Storage
rule-engine: ovirt-4.1+


Attachments (Terms of Use)
Screenshot (deleted)
2017-11-22 18:21 UTC, Aleksey
no flags Details
Logs (deleted)
2017-11-22 18:22 UTC, Aleksey
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 84378 None None None 2017-11-23 08:24:39 UTC
oVirt gerrit 84685 ovirt-engine-4.1 MERGED core: do not failover on MissingOvfFileFromVM 2017-12-11 16:28:49 UTC

Description Aleksey 2017-11-22 18:21:43 UTC
Created attachment 1357737 [details]
Screenshot

Description of problem:

Some time ago the problems started with the oVirt administrative web console.
When I try to open the sup-tab "Template import" for Export domain on tab "Storage" I get the error in sub-tub "Alerts"
 
VDSM command GetVmsInfoVDS failed: Missing OVF file from VM: (u'f4429fa5-76a2-45a7-ae3e-4d8955d4f1a6',)
 
All storages on tab "Storage" mark as down in web console.
The SPM-role begins frantically be transmitted from one host to another.
Screenshot attached.
 
All virtual machines at the same time working without stop
But I can't get a list of VMS stored on Export domain storage.
 
Recently this problem appeared and I deleted Export domain storage.
I completely deleted the Export domain storage from oVirt, formatted it, and then attached again to the oVirt
The problem is repeated again.


Version-Release number of selected component (if applicable):

oVirt Engine Version: 4.1.6.2-1.el7.centos

Comment 1 Aleksey 2017-11-22 18:22:37 UTC
Created attachment 1357738 [details]
Logs

Comment 3 Allon Mureinik 2017-11-22 19:39:08 UTC
Benny, I'm guessing https://gerrit.ovirt.org/#/c/84378/ is a fix for this?

Comment 4 Benny Zlotnik 2017-11-22 20:49:52 UTC
(In reply to Allon Mureinik from comment #3)
> Benny, I'm guessing https://gerrit.ovirt.org/#/c/84378/ is a fix for this?

It fixes the SPM failover issue, a separate patch is required the exception (probably log it as a warning) since it makes the VM Import tab inaccessible

Comment 5 Yosi Ben Shimon 2018-01-22 13:45:08 UTC
Can i get more info about how to reproduce it ?

Comment 6 Avihai 2018-01-22 14:50:14 UTC
(In reply to Benny Zlotnik from comment #4)
> (In reply to Allon Mureinik from comment #3)
> > Benny, I'm guessing https://gerrit.ovirt.org/#/c/84378/ is a fix for this?
> 
> It fixes the SPM failover issue, a separate patch is required the exception
> (probably log it as a warning) since it makes the VM Import tab inaccessible

Where is this separate patch (that logs this exception as a warning)? 
I do not see it in 'External Trackers' section .

Comment 7 Benny Zlotnik 2018-01-22 18:07:25 UTC
(In reply to Yosi Ben Shimon from comment #5)
> Can i get more info about how to reproduce it ?
You can export a VM to an export domain, then go to that SD, and remove the .ovf file from the VMs directory

(In reply to Avihai from comment #6)
> (In reply to Benny Zlotnik from comment #4)
> > (In reply to Allon Mureinik from comment #3)
> > > Benny, I'm guessing https://gerrit.ovirt.org/#/c/84378/ is a fix for this?
> > 
> > It fixes the SPM failover issue, a separate patch is required the exception
> > (probably log it as a warning) since it makes the VM Import tab inaccessible
> 
> Where is this separate patch (that logs this exception as a warning)? 
> I do not see it in 'External Trackers' section .

We eventually decided against it, as this issue is extremely rare (can be cause by a failed deletion of the vms directory) and quite simple to fix manually, and the code fix for it is quite risky.

Comment 8 Yosi Ben Shimon 2018-01-22 20:04:55 UTC
Tested according to Benny's comment #7 using:
ovirt-engine-4.1.9.1-0.1.el7.noarch

No error was thrown while OVF_STORE files were deleted.

Moving to VERIFIED.

Comment 9 Sandro Bonazzola 2018-01-24 10:40:30 UTC
This bugzilla is included in oVirt 4.1.9 release, published on Jan 24th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.1.9 release, published on Jan 24th 2018, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.