Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516482 - libmysqlclient.so.18 not found after upgrade to F27
Summary: libmysqlclient.so.18 not found after upgrade to F27
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mariadb
Version: 27
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Michal Schorm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-22 17:37 UTC by Erwan Legrand
Modified: 2018-02-04 21:49 UTC (History)
10 users (show)

Fixed In Version: mariadb-10.2.12-5.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-04 21:49:52 UTC


Attachments (Terms of Use)

Description Erwan Legrand 2017-11-22 17:37:00 UTC
Description of problem:
I use some software which links against libmysqlclient. After upgrading to F27, libmysqlclient is not found by the loader.

Version-Release number of selected component (if applicable):
$ rpm -q mariadb-libs
mariadb-libs-10.2.9-3.fc27.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Run software linked against libmysqlclient.so.

Actual results:
The following error is displayed when attempting to run software linked against libmysqlclient.
libmysqlclient.so.18: cannot open shared object file: No such file or directory

libmysqlclient is provided by mariadb-libs.
$ rpm -ql mariadb-libs
/etc/ld.so.conf.d/mariadb-x86_64.conf
/etc/my.cnf.d/client.cnf
/usr/lib/.build-id
/usr/lib/.build-id/a5
/usr/lib/.build-id/a5/c17835b924d9830cc6b91764d3c3e80f650d05
/usr/lib64/mysql/libmariadb.so.3
/usr/lib64/mysql/libmysqlclient.so.18

But ldconfig does not appear to know about it.
$ ldconfig -p | grep mysql
	libmariadb.so.3 (libc6,x86-64) => /usr/lib64/mysql/libmariadb.so.3
	libmariadb.so (libc6,x86-64) => /usr/lib64/mysql/libmariadb.so

Expected results:
libmysqlclient.so is successfully loaded.

Additional info:
Setting LD_LIBRARY_PATH=/usr/lib64/mysql works around the issue.

Comment 1 Erwan Legrand 2017-11-22 17:38:55 UTC
I should have said that the /usr/lib/mysql/libmysqlclient.so.18 symbolic link was missing after the upgrade. Running dnf reinstall mariadb-libs restored it.

Comment 2 Michal Schorm 2017-11-23 13:49:59 UTC
Hello,

TL;DR:
Do not use it. Rebuild your software with MariaDB library ( or MySQL, if you need exactly that one)

--

Longer story:

the situation is a little more complicated.

The mariadb library has changed to "libmariadb.so", so I started providing symbolic links to that library, since upstream claims it is 100% API & ABI compatibile. (Which proved itself not quite true, but upstream took care of the fixes, so it *should* be now).

The package had "Provides: libmysqlclient.so.18", which was an error after all, because I forgot to provide the file itself.
Later, I started big fedora mariadb/mysql update (currently present in rawhide) which transferred all packages to build with mariadb-connector-c instead. As the "libmysqlclient.so.18" was no longer needed, I decided to drop that false provides (which is currently done in Rawhide).

--

You should move to "mariadb.so" library (still referenced by "libmysqlclient.so" symlinks). Also, your software should be prepared for the rawhide update.

If you really need to build against "libmysqlclient.so.18", build against community-mysql package, however I'd recommend the first option.

Comment 3 Fedora Update System 2018-01-05 08:25:40 UTC
mysql-connector-odbc-5.3.9-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-5053d63074

Comment 4 Fedora Update System 2018-01-05 11:59:39 UTC
mysql-connector-odbc-5.3.9-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-5053d63074

Comment 5 2013temp2013temp 2018-01-09 20:59:54 UTC
Our site is having problem with the new mysql libraries:

2 problems: 

1-
ImportError: libmysqlclient.so.18: cannot open shared object file: No such file or directory

Actual solution:
get mariadb-libs-10.2.10-2.fc27.x86_64 from repository updates-testing
plus ln -s libmysqlclient.so libmysqlclient.so.18 in /usr/lib64

2-
apr_dbd_mysql.so not found if httpd config uses "DBDriver mysql"

Actual solution:
get apr-util-mysql-1.6.1-2.fc27.x86_64 from repository updates-testing

Comment 6 Fedora Update System 2018-01-15 18:33:52 UTC
mysql-connector-odbc-5.3.9-2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-50a0e9a0da

Comment 7 Fedora Update System 2018-01-17 16:19:50 UTC
mysql-connector-odbc-5.3.9-2.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2018-01-27 11:10:40 UTC
mariadb-10.2.12-5.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-66833616aa

Comment 9 Fedora Update System 2018-01-28 23:04:59 UTC
mariadb-10.2.12-5.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-66833616aa

Comment 10 Fedora Update System 2018-01-29 09:27:10 UTC
mariadb-10.2.12-5.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-66833616aa

Comment 11 Fedora Update System 2018-01-29 19:08:23 UTC
mariadb-10.2.12-5.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-66833616aa

Comment 12 Fedora Update System 2018-02-04 21:49:52 UTC
mariadb-10.2.12-5.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.