Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516481 - httpd wsgi segfault after service httpd reload
Summary: httpd wsgi segfault after service httpd reload
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Pulp
Version: 6.2.12
Hardware: x86_64
OS: Linux
high
high vote
Target Milestone: 6.3
Assignee: satellite6-bugs
QA Contact: Harshad More
URL:
Whiteboard:
: 1510589 (view as bug list)
Depends On:
Blocks: 1122832 1512426
TreeView+ depends on / blocked
 
Reported: 2017-11-22 17:36 UTC by Pavel Moravec
Modified: 2018-12-06 20:59 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1572298 (view as bug list)
Environment:
Last Closed: 2018-06-19 20:17:00 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Pulp Redmine 3129 High CLOSED - CURRENTRELEASE occasional httpd segfault 2018-02-28 02:32:00 UTC
Red Hat Product Errata RHBA-2018:1950 None None None 2018-06-19 20:18:04 UTC
Red Hat Knowledge Base (Solution) 3251441 None None None 2017-11-25 13:47:36 UTC

Comment 2 Pavel Moravec 2017-11-22 19:08:47 UTC
A small correction: segfault can rarely happen also when pulp.task queue delivers no message. But with much lower probability than when the queue is in use (and I think the more msgs are sent there, the higher the probability is).

Comment 3 Tanya Tereshchenko 2017-11-23 21:20:41 UTC
It's a dup of BZ#1510589 but description here is much more specific and contains a reproducer. Can we close BZ#1510589 as a dup of this BZ and not the other way around?

Comment 4 Pavel Moravec 2017-11-25 13:47:01 UTC
(In reply to Tanya Tereshchenko from comment #3)
> It's a dup of BZ#1510589 but description here is much more specific and
> contains a reproducer. Can we close BZ#1510589 as a dup of this BZ and not
> the other way around?

I havent realized there is already a BZ :( Sorry for DUP, close which one you prefer.

Few more observations:
- segfault happens also on "service httpd reload" (not force-reload specific)
- sometimes it seems the probability of hitting the segfault grows over the execution time of httpd service

Comment 5 Pavel Moravec 2017-11-27 17:20:30 UTC
My further understanding is the segfaulting process is one of:

apache   15093  4.2  0.4 1162584 74024 ?       Sl   17:58   0:00 (wsgi:pulp)     -DFOREGROUND

running before "service httpd restart" is executed. Since all those processes are killed and re-spawned by the service reload, there should not be much (if any) harm if a process segfaults just before it would be shut down (until it is in a middle of an operation, but backtraces show it is idle).

Comment 7 Dylan Gross 2017-11-30 21:46:54 UTC
*** Bug 1510589 has been marked as a duplicate of this bug. ***

Comment 9 pulp-infra@redhat.com 2017-11-30 23:33:51 UTC
The Pulp upstream bug status is at NEW. Updating the external tracker on this bug.

Comment 10 pulp-infra@redhat.com 2017-11-30 23:33:54 UTC
The Pulp upstream bug priority is at High. Updating the external tracker on this bug.

Comment 14 pulp-infra@redhat.com 2017-12-11 16:32:10 UTC
The Pulp upstream bug status is at ASSIGNED. Updating the external tracker on this bug.

Comment 15 pulp-infra@redhat.com 2017-12-18 19:02:26 UTC
The Pulp upstream bug status is at POST. Updating the external tracker on this bug.

Comment 17 pulp-infra@redhat.com 2018-01-05 13:31:41 UTC
The Pulp upstream bug status is at MODIFIED. Updating the external tracker on this bug.

Comment 18 pulp-infra@redhat.com 2018-01-05 14:01:28 UTC
All upstream Pulp bugs are at MODIFIED+. Moving this bug to POST.

Comment 19 pulp-infra@redhat.com 2018-02-20 18:32:24 UTC
The Pulp upstream bug status is at ON_QA. Updating the external tracker on this bug.

Comment 20 pulp-infra@redhat.com 2018-02-28 02:32:02 UTC
The Pulp upstream bug status is at CLOSED - CURRENTRELEASE. Updating the external tracker on this bug.

Comment 23 errata-xmlrpc 2018-06-19 20:17:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1950


Note You need to log in before you can comment on or make changes to this bug.