Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516457 - [Ceph-Ansible]: Installation of MDS fails in ubuntu through ceph-ansible
Summary: [Ceph-Ansible]: Installation of MDS fails in ubuntu through ceph-ansible
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 3.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: z1
: 3.0
Assignee: leseb
QA Contact: vidushi
Aron Gunn
URL:
Whiteboard:
Depends On:
Blocks: 1494421
TreeView+ depends on / blocked
 
Reported: 2017-11-22 16:21 UTC by Ramakrishnan Periyasamy
Modified: 2018-03-08 15:51 UTC (History)
12 users (show)

Fixed In Version: RHEL: ceph-ansible-3.0.16-1.el7cp Ubuntu: ceph-ansible_3.0.16-2redhat1
Doc Type: Bug Fix
Doc Text:
Previously, when attempting to install a Metadata Server (MDS) node in a cluster that runs on Ubuntu, the installation failed because the ceph-ansible utility could not install the ceph-common package. With this release, ceph-ansible will installs ceph-common as expected. As a result, the installation no longer fails in this case.
Clone Of:
Environment:
Last Closed: 2018-03-08 15:51:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0474 normal SHIPPED_LIVE Red Hat Ceph Storage 3.0 bug fix update 2018-03-08 20:51:53 UTC
Github ceph ceph-ansible pull 2207 None None None 2017-11-22 16:38:18 UTC

Description Ramakrishnan Periyasamy 2017-11-22 16:21:07 UTC
Description of problem:
MDS installation fails in ubuntu cluster using ceph-ansible

Error in Ansible:
***********************************
2017-11-22 15:44:30,943 p=22534 u=ubuntu |  task path: /usr/share/ceph-ansible/roles/ceph-common/tasks/main.yml:65
2017-11-22 15:44:30,956 p=22534 u=ubuntu |  [DEPRECATION WARNING]: always_run is deprecated. Use check_mode = no instead.. This feature will be removed in version 2.4. Deprecation warnings can be disabled by setting deprecation_warnings=False in 
ansible.cfg.
2017-11-22 15:44:30,982 p=22534 u=ubuntu |  Using module file /usr/lib/python2.7/dist-packages/ansible/modules/commands/command.py
2017-11-22 15:44:31,226 p=22534 u=ubuntu |  The full traceback is:
  File "/tmp/ansible_y6hZGQ/ansible_modlib.zip/ansible/module_utils/basic.py", line 2736, in run_command
    cmd = subprocess.Popen(args, **kwargs)
  File "/usr/lib/python2.7/subprocess.py", line 711, in __init__
    errread, errwrite)
  File "/usr/lib/python2.7/subprocess.py", line 1343, in _execute_child
    raise child_exception

2017-11-22 15:44:31,227 p=22534 u=ubuntu |  fatal: [magna031]: FAILED! => {
    "changed": false, 
    "cmd": "ceph --version", 
    "failed": true, 
    "invocation": {
        "module_args": {
            "_raw_params": "ceph --version", 
            "_uses_shell": false, 
            "chdir": null, 
            "creates": null, 
            "executable": null, 
            "removes": null, 
            "stdin": null, 
            "warn": true
        }
    }, 
    "msg": "[Errno 2] No such file or directory", 
    "rc": 2
}



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Configure MDS in ubuntu cluster using ubuntu ceph-ansible

Note: after installing "sudo apt-get install ceph-common" on MDS node manually ceph-ansible proceeds installation.

Logs available in this privatebin link: https://privatebin-it-iso.int.open.paas.redhat.com/?c8ac03c441ac4649#4O6zpwSF4Gblr9UipkVZNDuK8gi1iJGj7suejjLE6ok=

Comment 3 leseb 2017-11-22 16:49:17 UTC
Tag is upstream: https://github.com/ceph/ceph-ansible/releases/tag/v3.0.15
Ken, please build a package.

Thanks.

Comment 4 Neil Levine 2017-11-22 17:14:26 UTC
Let's release note this and get the fix into 3.0z1

Comment 5 Ken Dreyer (Red Hat) 2017-11-22 17:24:20 UTC
Based on Neil's comment, we won't respin RHCEPH 3.0 for this.

Comment 6 Harish NV Rao 2017-11-27 09:03:52 UTC
(In reply to Neil Levine from comment #4)
> Let's release note this and get the fix into 3.0z1

marking this bug as known issue.

Comment 8 leseb 2017-11-27 16:36:48 UTC
lgtm, thanks

Comment 12 vidushi 2018-02-05 12:53:12 UTC
No Issues seen during installation of MDS in ubuntu through ceph-ansible.
BZ verified for ceph-ansible 3.0.23-2redhat1.

Comment 15 errata-xmlrpc 2018-03-08 15:51:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0474


Note You need to log in before you can comment on or make changes to this bug.