Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516456 - Faile to setup heat output - ERROR: The Parameter (MessagingServices) was not provided.
Summary: Faile to setup heat output - ERROR: The Parameter (MessagingServices) was not...
Keywords:
Status: CLOSED DUPLICATE of bug 1516773
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: mathieu bultel
QA Contact: Yurii Prokulevych
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-22 16:17 UTC by Yurii Prokulevych
Modified: 2017-11-23 11:41 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-23 11:41:23 UTC


Attachments (Terms of Use)

Description Yurii Prokulevych 2017-11-22 16:17:36 UTC
Description of problem:
-----------------------
Attempt to setup heat's output on RHOS-12 env failed.
1st attempt just returned prompt to user after running for a while:
openstack overcloud update stack --init-minor-update --container-registry-file /home/stack/composable_roles/docker-images.yaml 2>&1 | tee overcloud_update_
setup.log
Waiting for messages on queue 'ba06cdcf-0ac1-449c-a91f-19a0aff2c595' with no timeout.
Started Mistral Workflow tripleo.package_update.v1.package_update_plan. Execution ID: 1cb1ffdb-bc18-4d38-85f9-ab68fd8dab3d
2017-11-22 14:04:39Z [ServiceNetMap]: UPDATE_IN_PROGRESS  state changed
...
2017-11-22 14:10:22Z [overcloud-Controller-fpntcrozkzyz-0-umlf5x6jehs6.NodeTLSData]: UPDATE_COMPLETE  state changed
2017-11-22 14:10:22Z [overcloud-Controller-fpntcrozkzyz-1-cjgzfibm5r3s.NodeTLSData]: UPDATE_COMPLETE  state changed
(undercloud) [stack@undercloud-0 ~ (undercloud-12-US)]$

Though stack's status was IN_PROGRESS
(undercloud) [stack@undercloud-0 ~ (undercloud-12-US)]$ openstack stack list
+--------------------------------------+------------+----------------------------------+--------------------+----------------------+----------------------+
| ID                                   | Stack Name | Project                          | Stack Status       | Creation Time        | Updated Time         |
+--------------------------------------+------------+----------------------------------+--------------------+----------------------+----------------------+
| 6c01509d-a121-4439-80e9-cfea604444e8 | overcloud  | 2fa0e547f1064d91bed3e3fe531d724b | UPDATE_IN_PROGRESS | 2017-11-22T09:48:34Z | 2017-11-22T14:04:22Z |
+--------------------------------------+------------+----------------------------------+--------------------+----------------------+----------------------+

Next resources were IN_PROGRESS:
undercloud) [root@undercloud-0 (undercloud-12-US)~]# openstack stack resource list --filter status=IN_PROGRESS --nested-depth 5 overcloud
+-----------------------+--------------------------------------+--------------------------------+--------------------+----------------------+---------------------------------------------------+
| resource_name         | physical_resource_id                 | resource_type                  | resource_status    | updated_time         | stack_name                                        |
+-----------------------+--------------------------------------+--------------------------------+--------------------+----------------------+---------------------------------------------------+
| CephStorage           | 4faef86c-24ab-4a5f-9416-3902440c2c50 | OS::Heat::ResourceGroup        | UPDATE_IN_PROGRESS | 2017-11-22T14:08:34Z | overcloud                                         |
| Controller            | 90322dae-8090-4daf-8c98-3092aa8d902e | OS::Heat::ResourceGroup        | UPDATE_IN_PROGRESS | 2017-11-22T14:08:37Z | overcloud                                         |
| Compute               | d3440cf3-c5f4-481f-923f-ef491e74ab5b | OS::Heat::ResourceGroup        | UPDATE_IN_PROGRESS | 2017-11-22T14:08:33Z | overcloud                                         |
| 1                     | c08883a1-4593-40f8-9d80-17e8a6b8092f | OS::TripleO::CephStorage       | UPDATE_IN_PROGRESS | 2017-11-22T14:08:40Z | overcloud-CephStorage-yku34nklg4ea                |
| 0                     | ca6e13fe-f828-469e-8632-99dc2e422ceb | OS::TripleO::CephStorage       | UPDATE_IN_PROGRESS | 2017-11-22T14:08:45Z | overcloud-CephStorage-yku34nklg4ea                |
| 2                     | 286719cb-c22e-42a1-882a-de173a757dea | OS::TripleO::CephStorage       | UPDATE_IN_PROGRESS | 2017-11-22T14:08:35Z | overcloud-CephStorage-yku34nklg4ea                |
| CephStorageDeployment | 30ba449c-9db0-4742-a72b-515a26d295c7 | OS::Heat::StructuredDeployment | UPDATE_IN_PROGRESS | 2017-11-22T14:10:02Z | overcloud-CephStorage-yku34nklg4ea-1-mjdmnzxcsla3 |
| 1                     | f1694143-a83e-4d55-ac6d-01b6ccc49f56 | OS::TripleO::Controller        | UPDATE_IN_PROGRESS | 2017-11-22T14:08:49Z | overcloud-Controller-fpntcrozkzyz                 |
| 0                     | 548eb6fd-d4fe-409b-b29e-5a72e9773f3e | OS::TripleO::Controller        | UPDATE_IN_PROGRESS | 2017-11-22T14:08:39Z | overcloud-Controller-fpntcrozkzyz                 |
| 2                     | 298399e5-085f-42bf-b9e3-908a2c2a6986 | OS::TripleO::Controller        | UPDATE_IN_PROGRESS | 2017-11-22T14:08:45Z | overcloud-Controller-fpntcrozkzyz                 |
| 1                     | 12c9a51c-b2e9-4254-84b9-1b5c7c535175 | OS::TripleO::Compute           | UPDATE_IN_PROGRESS | 2017-11-22T14:08:34Z | overcloud-Compute-ej3kgnmcvejv                    |
| 0                     | 2bb61e17-9f29-4365-b78f-91d28996001b | OS::TripleO::Compute           | UPDATE_IN_PROGRESS | 2017-11-22T14:08:39Z | overcloud-Compute-ej3kgnmcvejv                    |
| NovaComputeDeployment | 37cf735b-8f43-4a90-a1f8-d150c064ffb9 | OS::Heat::StructuredDeployment | UPDATE_IN_PROGRESS | 2017-11-22T14:10:00Z | overcloud-Compute-ej3kgnmcvejv-1-yuutawljkxct     |
| NovaComputeDeployment | e241f156-9d09-4f08-ab8f-bff19a8182a3 | OS::Heat::StructuredDeployment | UPDATE_IN_PROGRESS | 2017-11-22T14:10:08Z | overcloud-Compute-ej3kgnmcvejv-0-iieo4z4dplyc     |
+-----------------------+--------------------------------------+--------------------------------+--------------------+----------------------+---------------------------------------------------+


There were no changes for a while so I've restarted openstack-heat* services to put stack into FAILED state.

Attempt to re-run fails:

(undercloud) [stack@undercloud-0 ~ (undercloud-12-US)]$ openstack stack list
+--------------------------------------+------------+----------------------------------+---------------+----------------------+----------------------+
| ID                                   | Stack Name | Project                          | Stack Status  | Creation Time        | Updated Time         |
+--------------------------------------+------------+----------------------------------+---------------+----------------------+----------------------+
| 6c01509d-a121-4439-80e9-cfea604444e8 | overcloud  | 2fa0e547f1064d91bed3e3fe531d724b | UPDATE_FAILED | 2017-11-22T09:48:34Z | 2017-11-22T14:04:22Z |
+--------------------------------------+------------+----------------------------------+---------------+----------------------+----------------------+
(undercloud) [stack@undercloud-0 ~ (undercloud-12-US)]$ openstack overcloud update stack --init-minor-update --container-registry-file /home/stack/composable_roles/docker-images.yaml 2>&1 | tee overcloud_update_setup.1.log
ERROR: The Parameter (MessagingServices) was not provided.
(undercloud) [stack@undercloud-0 ~ (undercloud-12-US)]$ 

Seems like wrong roles_data.yaml file was picked up during minor update.

Deploy command:

openstack overcloud deploy --templates /usr/share/openstack-tripleo-heat-templates \
  -r /home/stack/composable_roles/roles/roles_data.yaml \
  -e /home/stack/composable_roles/roles/nodes.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml \
-e /home/stack/composable_roles/internal.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml \
-e /home/stack/composable_roles/network/network-environment.yaml \
-e /home/stack/composable_roles/enable-tls.yaml \
-e /home/stack/composable_roles/inject-trust-anchor.yaml \
-e /home/stack/composable_roles/public_vip.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/ssl/tls-endpoints-public-ip.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/ceph-ansible/ceph-ansible.yaml \
-e /home/stack/composable_roles/debug.yaml \
-e /home/stack/composable_roles/docker-images.yaml

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
openstack-heat-api-cfn-9.0.1-3.el7ost.noarch
openstack-heat-common-9.0.1-3.el7ost.noarch
python-heatclient-1.11.0-1.el7ost.noarch
python-heat-agent-1.4.1-0.20170824121708.ff31eb2.el7ost.noarch
openstack-heat-api-9.0.1-3.el7ost.noarch
heat-cfntools-1.3.0-2.el7ost.noarch
openstack-tripleo-heat-templates-7.0.3-10.el7ost.noarch
openstack-heat-engine-9.0.1-3.el7ost.noarch
puppet-heat-11.3.1-0.20171030032721.182b979.el7ost.noarch

Expected result:
----------------
Available to re-run command.

Additional info:
----------------
Virtual setup: 3controllers + 3database + 3messaging + 2networker + 3ceph + 2computes

Comment 1 Lukas Bezdicka 2017-11-23 11:41:23 UTC
Caused by overridden roles_data.yaml - stack got broken completly.

*** This bug has been marked as a duplicate of bug 1516773 ***


Note You need to log in before you can comment on or make changes to this bug.