Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516433 - [abrt] dnfdragora: Py_FatalError(): python3.6 killed by SIGABRT
Summary: [abrt] dnfdragora: Py_FatalError(): python3.6 killed by SIGABRT
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnfdragora
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Björn 'besser82' Esser
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:579bd873428aff23e1c535f3923...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-22 15:45 UTC by Steve
Modified: 2018-08-19 06:51 UTC (History)
18 users (show)

Fixed In Version: dnfdragora-1.0.1-8.git20171229.24e4647.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-31 21:28:42 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2017-11-22 15:45 UTC, Steve
no flags Details
File: cgroup (deleted)
2017-11-22 15:45 UTC, Steve
no flags Details
File: core_backtrace (deleted)
2017-11-22 15:45 UTC, Steve
no flags Details
File: cpuinfo (deleted)
2017-11-22 15:45 UTC, Steve
no flags Details
File: dso_list (deleted)
2017-11-22 15:45 UTC, Steve
no flags Details
File: environ (deleted)
2017-11-22 15:45 UTC, Steve
no flags Details
File: limits (deleted)
2017-11-22 15:45 UTC, Steve
no flags Details
File: maps (deleted)
2017-11-22 15:45 UTC, Steve
no flags Details
File: mountinfo (deleted)
2017-11-22 15:45 UTC, Steve
no flags Details
File: open_fds (deleted)
2017-11-22 15:45 UTC, Steve
no flags Details
File: proc_pid_status (deleted)
2017-11-22 15:45 UTC, Steve
no flags Details

Description Steve 2017-11-22 15:45:05 UTC
Version-Release number of selected component:
dnfdragora-1.0.1-6.git20170505.2a3b056.fc27

Additional info:
reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora
crash_function: Py_FatalError
executable:     /usr/bin/python3.6
journald_cursor: s=696d8d768b3644789f3ebf4a5e289a04;i=13d2;b=d11011a2b96449b394a7eedb0b64a2db;m=31739479fc;t=55e942aa89147;x=7f952e11af9fb139
kernel:         4.13.13-300.fc27.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Potential duplicate: bug 1439247

Comment 1 Steve 2017-11-22 15:45:12 UTC
Created attachment 1357632 [details]
File: backtrace

Comment 2 Steve 2017-11-22 15:45:13 UTC
Created attachment 1357633 [details]
File: cgroup

Comment 3 Steve 2017-11-22 15:45:15 UTC
Created attachment 1357634 [details]
File: core_backtrace

Comment 4 Steve 2017-11-22 15:45:17 UTC
Created attachment 1357635 [details]
File: cpuinfo

Comment 5 Steve 2017-11-22 15:45:18 UTC
Created attachment 1357636 [details]
File: dso_list

Comment 6 Steve 2017-11-22 15:45:20 UTC
Created attachment 1357637 [details]
File: environ

Comment 7 Steve 2017-11-22 15:45:21 UTC
Created attachment 1357638 [details]
File: limits

Comment 8 Steve 2017-11-22 15:45:23 UTC
Created attachment 1357639 [details]
File: maps

Comment 9 Steve 2017-11-22 15:45:25 UTC
Created attachment 1357640 [details]
File: mountinfo

Comment 10 Steve 2017-11-22 15:45:26 UTC
Created attachment 1357641 [details]
File: open_fds

Comment 11 Steve 2017-11-22 15:45:28 UTC
Created attachment 1357642 [details]
File: proc_pid_status

Comment 12 Alan 2017-11-30 14:25:49 UTC
Similar problem has been detected:

1) select all packages for update
2) deselect kernel packages
3) press 'apply' button

reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: Py_FatalError
executable:     /usr/bin/python3.6
journald_cursor: s=bb123aa53c984d3d89db9d2b0fdcaf3b;i=25ca;b=54e32edce20043d89d7016f8d0aa44e9;m=b344ed5f0a;t=55f33d4a1c448;x=2267ba253c6ac85e
kernel:         4.13.13-300.fc27.x86_64
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         python3.6 killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 13 Eugene Mah 2017-12-06 14:49:26 UTC
Similar problem has been detected:

Was using dnfdragora to install a package when dnfdragora crashed

reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora
crash_function: Py_FatalError
executable:     /usr/bin/python3.6
journald_cursor: s=a1b24ce9efc242bea73d05e055a4d317;i=c6077;b=7e73ad2c53b94f538dd7b927286d1ad1;m=1bae74b2c;t=55facee76ee6c;x=5f68943e4516e27
kernel:         4.13.16-302.fc27.x86_64
package:        dnfdragora-1.0.1-6.git20170505.2a3b056.fc27
reason:         python3.6 killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 14 Ronald L Humble 2017-12-12 12:18:08 UTC
Similar problem has been detected:

Right clicked on Xfce4 icon. Updates appeared that had been applied via dnf in terminal days ago. Selected firefox and 'Apply'. Crash.

reporter:       libreport-2.9.3
.~lock.environ#: ,rhumble,120gb,12.12.2017 07:17,file:///home/rhumble/.config/libreoffice/4;
backtrace_rating: 4
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: Py_FatalError
executable:     /usr/bin/python3.6
journald_cursor: s=bb7fecd5cb504700973b0ace4de48a49;i=30739;b=79eff2fdebd54edb90e41a1f7f4a840e;m=33994ec0;t=560236e842109;x=9954d9be5eadf7e0
kernel:         4.13.16-302.fc27.x86_64
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         python3.6 killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 15 Fedora Update System 2017-12-29 23:24:10 UTC
dnfdaemon-0.3.18-5.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06

Comment 16 Fedora Update System 2017-12-29 23:28:13 UTC
dnfdaemon-0.3.18-5.fc26 dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b

Comment 17 Fedora Update System 2017-12-30 19:55:03 UTC
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06

Comment 18 Fedora Update System 2017-12-30 20:40:49 UTC
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b

Comment 19 Fedora Update System 2017-12-31 21:28:42 UTC
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2018-01-01 22:12:17 UTC
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 21 Kazimieras Vaina 2018-01-02 07:52:31 UTC
Similar problem has been detected:

started an update

reporter:       libreport-2.9.3
backtrace_rating: 3
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: Py_FatalError
executable:     /usr/bin/python3.6
journald_cursor: s=798c8b6aaad843be91f498df880f2570;i=1269a1a;b=ded0b55b6bb24226b08c120ad6ec337d;m=50c4e496aa;t=561c5cc986c5a;x=b35ef986309928e8
kernel:         4.14.8-300.fc27.x86_64
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         python3.6 killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 22 francko 2018-01-04 08:49:08 UTC
*** Bug 1530927 has been marked as a duplicate of this bug. ***

Comment 23 Jean-Philippe 2018-01-05 20:06:30 UTC
*** Bug 1531687 has been marked as a duplicate of this bug. ***

Comment 24 Steve 2018-02-04 07:05:52 UTC
Similar problem has been detected:

Just clicked 'Apply'.

reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        python3 /usr/bin/dnfdragora-updater
crash_function: Py_FatalError
executable:     /usr/bin/python3.6
journald_cursor: s=329f18aaaecc45188fabe4debed691af;i=1054;b=5e1adf9e35264ee584f9a063ea154aab;m=20b46ed983;t=5645d7d1f1c6d;x=8783d378c2a25b89
kernel:         4.14.16-300.fc27.x86_64
package:        dnfdragora-updater-1.0.1-9.git20180108.b0e8a66.fc27
reason:         python3.6 killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 25 Eduardo Medina 2018-02-16 23:20:48 UTC
*** Bug 1546397 has been marked as a duplicate of this bug. ***

Comment 26 chris goodwin 2018-02-27 01:01:10 UTC
Similar problem has been detected:

pwered on, tried to open dnfdragon... then resized, then crash.

reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        python3 /usr/bin/dnfdragora-updater
crash_function: Py_FatalError
executable:     /usr/bin/python3.6
journald_cursor: s=54f20218759d4a1f8d66308e92206599;i=1c97f;b=cbd1bb72098c44218dca5aade3d65fb7;m=617a3dc;t=56626ee5f6989;x=34fde4313561d9ea
kernel:         4.15.4-300.fc27.x86_64
package:        dnfdragora-updater-1.0.1-9.git20180108.b0e8a66.fc27
reason:         python3.6 killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 27 Moritz Kammerer 2018-02-28 10:19:15 UTC
*** Bug 1550020 has been marked as a duplicate of this bug. ***

Comment 28 Liviu Vartolomei 2018-03-07 03:32:57 UTC
*** Bug 1552387 has been marked as a duplicate of this bug. ***

Comment 29 PhiRatio 2018-04-03 05:30:26 UTC
*** Bug 1563051 has been marked as a duplicate of this bug. ***

Comment 30 Stefan Gies 2018-04-22 05:35:19 UTC
*** Bug 1570346 has been marked as a duplicate of this bug. ***

Comment 31 Richard Hollins 2018-08-19 01:34:45 UTC
Similar problem has been detected:

I had just tried to open dnf-dragora.  Window opened,  the frame was normal, but the interior of the window was black.  after about 30 sec. Problem Reporting came up with "dnfdragora quit unexpectedly".

reporter:       libreport-2.9.5
backtrace_rating: 4
cmdline:        python3 /usr/bin/dnfdragora
crash_function: Py_FatalError
executable:     /usr/bin/python3.6
journald_cursor: s=f7021f8eee8a4b659fa65521127c78e5;i=4c33;b=be76c725c7904e0bbbc38ab4d8020c48;m=aace5c6;t=56d785bc194e4;x=fabab08bea02cac0
kernel:         4.15.15-300.fc27.x86_64
package:        dnfdragora-1.0.1-9.git20180108.b0e8a66.fc27
reason:         python3.6 killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000


Note You need to log in before you can comment on or make changes to this bug.