Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516426 - Webadmin: cluster "Native Access on gluster storage domain" checkbox is not updated.
Summary: Webadmin: cluster "Native Access on gluster storage domain" checkbox is not u...
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Gluster
Version: 4.1.7.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ---
: ---
Assignee: Sahina Bose
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-22 15:28 UTC by Nisim Simsolo
Modified: 2018-03-09 09:54 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-09 09:54:57 UTC
oVirt Team: Gluster


Attachments (Terms of Use)
screen video (deleted)
2017-11-22 15:32 UTC, Nisim Simsolo
no flags Details
engine.log (deleted)
2017-11-22 15:33 UTC, Nisim Simsolo
no flags Details

Description Nisim Simsolo 2017-11-22 15:28:46 UTC
Description of problem:
When checking cluster tab -> edit cluster -> general -> Additional features supported in the Cluster -> "Native Access on gluster storage domain" checkbox and clicking "ok" button, it looks like the configuration applied.
Browsing again "edit cluster" shows that this checkbox is unchecked.

Version-Release number of selected component (if applicable):
ovirt-engine-4.1.8-0.1.el7
vdsm-4.19.36-1.el7ev.x86_64
libvirt-client-3.2.0-14.el7_4.3.x86_64
qemu-kvm-rhev-2.9.0-16.el7_4.8.x86_64
sanlock-3.5.0-1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Browse webadmin -> cluster tab -> edit cluster -> general -> Additional features supported in the Cluster, check "Native Access on gluster storage domain" checkbox
2. Click OK.
3. Browse same path again.

Actual results:
2. there is no failure message in events tab and it looks like the action applied properly.
3. Checkbox remain unchecked.

Expected results:
If applying this checkbox, it should remain checked or notifying why applying this value failed.

Additional info:
screen video and engine.log attached.

Comment 1 Nisim Simsolo 2017-11-22 15:32:34 UTC
Created attachment 1357626 [details]
screen video

Comment 2 Nisim Simsolo 2017-11-22 15:33:56 UTC
Created attachment 1357627 [details]
engine.log

Comment 3 Sahina Bose 2018-03-09 09:54:57 UTC
Closing this as we have removed the ability to enable gluster native access per cluster.


Note You need to log in before you can comment on or make changes to this bug.