Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516412 - While managing a block storage domain, moving too fast to Targets > LUNs table resets lun's isInclude() check-mark
Summary: While managing a block storage domain, moving too fast to Targets > LUNs tabl...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ovirt-4.2.1
: ---
Assignee: shani
QA Contact: Natalie Gavrielov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-22 15:09 UTC by shani
Modified: 2018-02-12 11:51 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-12 11:51:57 UTC
oVirt Team: Storage
rule-engine: ovirt-4.2+
ylavi: ovirt-4.3+


Attachments (Terms of Use)
When moving to Targets > LUNs table immediately, the storage domain's included luns can't been detected. (deleted)
2017-11-22 15:09 UTC, shani
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 85781 master MERGED webadmin: Add "in progress" animation while loading LUNs' table 2017-12-27 17:07:25 UTC

Description shani 2017-11-22 15:09:25 UTC
Created attachment 1357597 [details]
When moving to Targets > LUNs table immediately, the storage domain's included luns can't been detected.

Description of problem:
When managing a block storage domain, the opened dialogue shows LUNs > Targets table.
In case of moving to Targets > LUNs table immediately, the storage domain's included luns can't been detected (there's no green V next to them).
Also, in case the lun can be extended, it has no longer an 'available size'. 

Version-Release number of selected component (if applicable):
4.2.0

How reproducible:
100%

Steps to Reproduce:
1. Manage an isaci data storage domain
2. Wait until dialogue is fully uploaded and notice the included luns on LUNs > Targets table. 
3. Close the dialogue and re-open it with clicking immediately on Targts > LUNs
4. Switch back to LUNs > Targets table.

Actual results:
There's no green V next to the included luns, and also there's no available size for extending. 

Expected results:
Data should appear as before.

Additional info:
See attached gif for visualization.

Comment 1 Natalie Gavrielov 2018-02-06 14:51:41 UTC
Verified using rhvm-4.2.1.4-0.1.el7.noarch

Comment 2 Sandro Bonazzola 2018-02-12 11:51:57 UTC
This bugzilla is included in oVirt 4.2.1 release, published on Feb 12th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.1 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.