Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516410 - Incorrect response code for creation docker repository using invalid name
Summary: Incorrect response code for creation docker repository using invalid name
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Repositories
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-22 15:05 UTC by Oleg Dovzhenko
Modified: 2019-02-07 12:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-07 12:03:51 UTC


Attachments (Terms of Use)
Production log (deleted)
2017-11-22 15:05 UTC, Oleg Dovzhenko
no flags Details

Description Oleg Dovzhenko 2017-11-22 15:05:33 UTC
Created attachment 1357596 [details]
Production log

Description of problem:
We got 500 response code when trying to create docker repository with invalid name

Version-Release number of selected component (if applicable):
Satellite 6.3.0 snap 25
foreman-1.15.6.9-1.el7sat.noarch
foreman-bootloaders-redhat-201707171807-1.el7sat.noarch
foreman-bootloaders-redhat-tftpboot-201707171807-1.el7sat.noarch
foreman-cli-1.15.6.9-1.el7sat.noarch
foreman-compute-1.15.6.9-1.el7sat.noarch
foreman-debug-1.15.6.9-1.el7sat.noarch
foreman-discovery-image-3.4.1-3.el7sat.noarch
foreman-ec2-1.15.6.9-1.el7sat.noarch
foreman-gce-1.15.6.9-1.el7sat.noarch
foreman-installer-1.15.6.4-1.el7sat.noarch
foreman-installer-katello-3.4.5.12-1.el7sat.noarch
foreman-libvirt-1.15.6.9-1.el7sat.noarch
foreman-openstack-1.15.6.9-1.el7sat.noarch
foreman-ovirt-1.15.6.9-1.el7sat.noarch
foreman-postgresql-1.15.6.9-1.el7sat.noarch
foreman-proxy-1.15.6.1-1.el7sat.noarch
foreman-proxy-content-3.4.5-6.el7sat.noarch
foreman-rackspace-1.15.6.9-1.el7sat.noarch
foreman-selinux-1.15.5-1.el7sat.noarch
foreman-vmware-1.15.6.9-1.el7sat.noarch
hp-dl120gen9-04.rhts.eng.bos.redhat.com-foreman-client-1.0-1.noarch
hp-dl120gen9-04.rhts.eng.bos.redhat.com-foreman-proxy-1.0-2.noarch
hp-dl120gen9-04.rhts.eng.bos.redhat.com-foreman-proxy-client-1.0-1.noarch
katello-3.4.5-6.el7sat.noarch
katello-certs-tools-2.4.0-1.el7sat.noarch
katello-client-bootstrap-1.4.2-1.el7sat.noarch
katello-common-3.4.5-6.el7sat.noarch
katello-debug-3.4.5-6.el7sat.noarch
katello-default-ca-1.0-1.noarch
katello-installer-base-3.4.5.12-1.el7sat.noarch
katello-selinux-3.0.2-1.el7sat.noarch
katello-server-ca-1.0-1.noarch
katello-service-3.4.5-6.el7sat.noarch
pulp-katello-1.0.2-1.el7sat.noarch
puppet-foreman_scap_client-0.3.16-1.el7sat.noarch
satellite-6.3.0-21.0.beta.el7sat.noarch
satellite-cli-6.3.0-21.0.beta.el7sat.noarch
satellite-common-6.3.0-21.0.beta.el7sat.noarch
satellite-installer-6.3.0.9-1.beta.el7sat.noarch
tfm-rubygem-foreman_bootdisk-9.0.0-2.fm1_15.el7sat.noarch
tfm-rubygem-foreman_discovery-9.1.5-1.fm1_15.el7sat.noarch
tfm-rubygem-foreman_docker-3.1.0-1.fm1_15.el7sat.noarch
tfm-rubygem-foreman_hooks-0.3.14-1.fm1_15.el7sat.noarch
tfm-rubygem-foreman_openscap-0.7.10-1.fm1_15.el7sat.noarch
tfm-rubygem-foreman-redhat_access-2.0.12-1.el7sat.noarch
tfm-rubygem-foreman_remote_execution-1.3.7-1.fm1_15.el7sat.noarch
tfm-rubygem-foreman_remote_execution_core-1.0.6-1.fm1_15.el7sat.noarch
tfm-rubygem-foreman-tasks-0.9.6-1.fm1_15.el7sat.noarch
tfm-rubygem-foreman-tasks-core-0.1.8-1.fm1_15.el7sat.noarch
tfm-rubygem-foreman_theme_satellite-1.0.4.12-1.el7sat.noarch
tfm-rubygem-foreman_virt_who_configure-0.1.8-1.fm1_15.el7sat.noarch
tfm-rubygem-hammer_cli_foreman-0.11.0.5-1.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_admin-0.0.7-1.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3.3-2.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_discovery-1.0.0-1.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.6-2.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_openscap-0.1.5-1.fm1_15.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_remote_execution-0.0.6-1.fm1_15.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.12-1.fm1_15.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_virt_who_configure-0.0.3-1.el7sat.noarch
tfm-rubygem-hammer_cli_katello-0.11.3.1-1.el7sat.noarch
tfm-rubygem-katello-3.4.5.27-1.el7sat.noarch
tfm-rubygem-katello_ostree-3.4.5.27-1.el7sat.noarch


How reproducible:
Always

Steps to Reproduce:
1. Make request
2017-11-22 16:00:52 - nailgun.client - DEBUG - Making HTTP POST request to https://hp-dl120gen9-04.rhts.eng.bos.redhat.com/katello/api/v2/repositories with options {'verify': False, 'auth': ('admin', 'changeme'), 'headers': {'content-type': 'application/json'}}, no params and data {"product_id": 402, "url": "https://registry-1.docker.io", "docker_upstream_name": "busybox", "content_type": "docker", "name": "<h6>eOfbZTSh</h6>"}.


Actual results:
In response we have 500 status code
2017-11-22 16:00:53 - nailgun.client - WARNING - Received HTTP 500 response: {"displayMessage":"A validation error occurred.","errors":["A validation error occurred."]}

Expected results:
In response we have 422 response code

Additional info:
For yum repository this works as expected
2017-11-22 16:48:20 - nailgun.client - DEBUG - Making HTTP POST request to https://hp-dl120gen9-04.rhts.eng.bos.redhat.com/katello/api/v2/repositories with options {'verify': False, 'auth': ('admin', 'changeme'), 'headers': {'content-type': 'application/json'}}, no params and data {"product_id": 415, "content_type": "yum", "url": "http://inecas.fedorapeople.org/fakerepos/zoo3/", "name": "TfUDAvxAWBSFmAiKRylcjesTrvWRguiCiACbvEVlYUkuGVZNEnWObdKwhZSRgHupFbWcXGhotwvWzCGnmSWrXKOkvTXEsKGhCnzCTwyrSESuuRLuJcubjanySOBywMSeJgXXbYdtiOBzxBRRyhRoOHMMTLDYPqAVcBlfZxvWXuEZaUTWCVXoZLtwjJXKQBgwYFPqWWvqClsRyzQzXfZDiSHckZyueNbxRAfHmgmyLAhelPCEjwyYxKgmHYFoDpVktwmxaBqyVsfVAkwGuykmqjxtDDzBtJLPwZBchecdBoES"}.
2017-11-22 16:48:22 - nailgun.client - WARNING - Received HTTP 422 response: {"displayMessage":"Validation failed: Name is too long (maximum is 255 characters)","errors":{"name":["is too long (maximum is 255 characters)"]}}

Comment 2 Bryan Kearney 2018-11-30 15:00:58 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Rich Jerrido or Bryan Kearney or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 3 Bryan Kearney 2019-02-07 12:03:51 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.