Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516404 - mutter does not remember saved multi monitor configuration
Summary: mutter does not remember saved multi monitor configuration
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: mutter
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Florian Müllner
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On: 1512448
Blocks: 1481395
TreeView+ depends on / blocked
 
Reported: 2017-11-22 14:51 UTC by Tomas Pelka
Modified: 2018-05-17 14:39 UTC (History)
5 users (show)

Fixed In Version: mutter-3.26.2-6.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1512448
Environment:
Last Closed: 2018-04-10 13:07:25 UTC
Target Upstream Version:


Attachments (Terms of Use)
modetest when I configured and save my monitor setup (deleted)
2017-11-22 15:25 UTC, Tomas Pelka
no flags Details
modetest when I re-dock (deleted)
2017-11-22 16:29 UTC, Tomas Pelka
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0770 None None None 2018-04-10 13:08:27 UTC
GNOME Bugzilla 787629 None None None 2017-11-22 15:00:35 UTC

Description Tomas Pelka 2017-11-22 14:51:49 UTC
Description of problem:
mutter can't save display layout configuration when fractional scaling is enabled and not only when scaling is enabled

My particular config:
1x full HD monitor
1x QHD monitor with fractional scaling 125%
laptop lid closed, build in display off

Version-Release number of selected component (if applicable):
control-center-3.26.2-1.el7
mutter-3.26.2-3.el7

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:
(gnome-control-center:8374): display-cc-panel-WARNING **: Config not applicable: GDBus.Error:org.freedesktop.DBus.Error.InvalidArgs: Logical monitors not adjecent

Expected results:


Additional info:
I started to file this bz in rhbz1512448 so maybe look there for more initial info.

Comment 1 Tomas Pelka 2017-11-22 15:25:53 UTC
Created attachment 1357604 [details]
modetest when I configured and save my monitor setup

Comment 2 Tomas Pelka 2017-11-22 16:29:21 UTC
Created attachment 1357668 [details]
modetest when I re-dock

Comment 11 errata-xmlrpc 2018-04-10 13:07:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0770


Note You need to log in before you can comment on or make changes to this bug.