Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516390 - w2k16 RHEV-Agent 4.0.7 does not run after start
Summary: w2k16 RHEV-Agent 4.0.7 does not run after start
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhev-guest-tools
Version: 4.0.7
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-4.1.9
: ---
Assignee: Lev Veyde
QA Contact: Jiri Belka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-22 14:25 UTC by Jiri Belka
Modified: 2018-01-09 10:29 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1524185 (view as bug list)
Environment:
Last Closed: 2018-01-09 10:29:13 UTC
oVirt Team: Integration


Attachments (Terms of Use)

Description Jiri Belka 2017-11-22 14:25:54 UTC
Description of problem:

WGT 4.0.7 RHEV-Agent does not run after reboot even it is enabled by default.

- from eventlog:

Error	11/22/2017 11:46:12 AM	Service Control Manager	7009	None	A timeout was reached (30000 milliseconds) while waiting for the RHEV-Agent service to connect.
Error	11/22/2017 11:46:12 AM	Service Control Manager	7000	None	"The CIRunner service failed to start due to the following error: 
The service did not respond to the start or control request in a timely fashion."
Error	11/22/2017 11:46:12 AM	Service Control Manager	7009	None	A timeout was reached (30000 milliseconds) while waiting for the CIRunner service to connect.

starting manually works

Version-Release number of selected component (if applicable):
4.0.7

How reproducible:
100%

Steps to Reproduce:
1. install 4.0.6 and update to 4.0.7
2. reboot
3. check if rhev-agent is running

Actual results:
rhev-agent not running

Expected results:
should run

Additional info:

Comment 2 Lev Veyde 2017-11-22 14:56:32 UTC
(In reply to Jiri Belka from comment #0)
> Description of problem:
> 
> WGT 4.0.7 RHEV-Agent does not run after reboot even it is enabled by default.
> 
> - from eventlog:
> 
> Error	11/22/2017 11:46:12 AM	Service Control Manager	7009	None	A timeout was
> reached (30000 milliseconds) while waiting for the RHEV-Agent service to
> connect.
> Error	11/22/2017 11:46:12 AM	Service Control Manager	7000	None	"The CIRunner
> service failed to start due to the following error: 
> The service did not respond to the start or control request in a timely
> fashion."
> Error	11/22/2017 11:46:12 AM	Service Control Manager	7009	None	A timeout was
> reached (30000 milliseconds) while waiting for the CIRunner service to
> connect.
> 
> starting manually works
> 
> Version-Release number of selected component (if applicable):
> 4.0.7
> 
> How reproducible:
> 100%
> 
> Steps to Reproduce:
> 1. install 4.0.6 and update to 4.0.7
> 2. reboot
> 3. check if rhev-agent is running
> 
> Actual results:
> rhev-agent not running
> 
> Expected results:
> should run
> 
> Additional info:

The eventlog entries are of the WGT-CI CIRunner daemon, not the RHEV/oVirt Agent.

Comment 3 Lev Veyde 2017-11-22 15:02:18 UTC
(In reply to Lev Veyde from comment #2)
> (In reply to Jiri Belka from comment #0)
> > Description of problem:
> > 
> > WGT 4.0.7 RHEV-Agent does not run after reboot even it is enabled by default.
> > 
> > - from eventlog:
> > 
> > Error	11/22/2017 11:46:12 AM	Service Control Manager	7009	None	A timeout was
> > reached (30000 milliseconds) while waiting for the RHEV-Agent service to
> > connect.
> > Error	11/22/2017 11:46:12 AM	Service Control Manager	7000	None	"The CIRunner
> > service failed to start due to the following error: 
> > The service did not respond to the start or control request in a timely
> > fashion."
> > Error	11/22/2017 11:46:12 AM	Service Control Manager	7009	None	A timeout was
> > reached (30000 milliseconds) while waiting for the CIRunner service to
> > connect.
> > 
> > starting manually works
> > 
> > Version-Release number of selected component (if applicable):
> > 4.0.7
> > 
> > How reproducible:
> > 100%
> > 
> > Steps to Reproduce:
> > 1. install 4.0.6 and update to 4.0.7
> > 2. reboot
> > 3. check if rhev-agent is running
> > 
> > Actual results:
> > rhev-agent not running
> > 
> > Expected results:
> > should run
> > 
> > Additional info:
> 
> The eventlog entries are of the WGT-CI CIRunner daemon, not the RHEV/oVirt
> Agent.

I mean the last 2.

Looks like that both CIRunner daemon and RHEV-Agent services failed for the same reason during the startup.

What OS version it was tested under?

Comment 4 Jiri Belka 2017-11-22 15:07:19 UTC
w2k16

Comment 5 Jiri Belka 2017-11-23 09:39:19 UTC
i upgraded from 4.0.7 to 4.1.7 and still (now renamed) ovirt-guest-agent does not run after boot. starting it manually works ok.

Comment 6 Jiri Belka 2017-11-23 09:47:30 UTC
I see after 4.1.7 is installed this event after boot:

The description for Event ID 4098 from source OVirtGuestService cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event: 

OVirtGuestService

Comment 7 Jiri Belka 2017-11-23 10:30:26 UTC
The issue exists also on clean install of w2k16 with 4.1.7.

Comment 9 Lev Veyde 2017-11-23 22:51:40 UTC
(In reply to Jiri Belka from comment #8)
> Created attachment 1358356 [details]
> logs and eventvwr from clean installed w2k16 and 4.0.6->4.0.7

Went over the logs and couldn't find anything unusual.

In fact the RHEV Guest agent is actually the same in both 4.0-6 and 4.0-7, so the system doesn't do much in this case.

Basically the service stays the same it was in 4.0-6.

Can you please send the logs from the 4.0-6 installation?

Also can you please test what happens with the clean install and upgrade of/to 4.1-7 ?

I think that we verified this before, but let's recheck that this actually works.

Comment 10 Jiri Belka 2017-11-24 10:11:23 UTC
> Can you please send the logs from the 4.0-6 installation?

4.0.6 is ok, GA is running fine after boot.

> Also can you please test what happens with the clean install and upgrade
> of/to 4.1-7 ?

Surprisingly upgrade from 4.0.6 to 4.1.7 works ok and GA is running after boot.

Comment 13 Jiri Belka 2017-11-24 14:53:58 UTC
I think I isolated the issue - it is related to 4.0.7. Even clean install of WGT 4.0.7 has GA not running after start. Clean install of 4.1.7 is OK.

Comment 15 Sandro Bonazzola 2017-11-27 08:12:45 UTC
(In reply to Jiri Belka from comment #13)
> I think I isolated the issue - it is related to 4.0.7. Even clean install of
> WGT 4.0.7 has GA not running after start. Clean install of 4.1.7 is OK.

Let's ensure it works for 4.1.8 too.

Comment 18 Jiri Belka 2017-11-27 14:54:51 UTC
(In reply to Sandro Bonazzola from comment #15)
> (In reply to Jiri Belka from comment #13)
> > I think I isolated the issue - it is related to 4.0.7. Even clean install of
> > WGT 4.0.7 has GA not running after start. Clean install of 4.1.7 is OK.
> 
> Let's ensure it works for 4.1.8 too.

There's no WGT 4.1.8 and I am not sure anything was worked on WGT since 4.1.7, Lev?

Comment 19 Lev Veyde 2017-11-27 14:57:02 UTC
(In reply to Jiri Belka from comment #18)
> (In reply to Sandro Bonazzola from comment #15)
> > (In reply to Jiri Belka from comment #13)
> > > I think I isolated the issue - it is related to 4.0.7. Even clean install of
> > > WGT 4.0.7 has GA not running after start. Clean install of 4.1.7 is OK.
> > 
> > Let's ensure it works for 4.1.8 too.
> 
> There's no WGT 4.1.8 and I am not sure anything was worked on WGT since
> 4.1.7, Lev?

Jiri - I meant oVirt/RHV 4.1.8 - w/ WGT 4.1-7 of course.

Comment 20 Jiri Belka 2017-11-27 15:08:56 UTC
The issue does exist in situation when somebody upgrade to latest (for today 4.0.7) WGT in 4.0 rhv channel - #13. Proposing upgrade to latest (for today 4.1.7) WGT in 4.1 rhv channel did not seem to fix the issue - #5.

Please, provide updated 4.1.x WGT so we can try to test if migration from 4.0.x to 4.1.x would solve the issue.

Comment 24 Jiri Belka 2017-11-30 15:41:38 UTC
4.0-8 - same story, GA not running after boot.

Comment 30 Yedidyah Bar David 2017-12-10 15:38:45 UTC
Cloned to bug 1524185 on the agent. I think we should fix it and revert the fix on current bug, which was to postpone starting the agent on reboot.

Comment 31 Lev Veyde 2018-01-09 10:29:13 UTC
After internal discussions it was decided that since the issue is only visible in one env. and the workaround causes significant delay starting the agent, which will negatively affect all users,  we won't push the packages with this workaround to all users.


Note You need to log in before you can comment on or make changes to this bug.