Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516380 - Package python-pulp-agent-lib from Sat client repo blocks upgrade
Summary: Package python-pulp-agent-lib from Sat client repo blocks upgrade
Keywords:
Status: CLOSED DUPLICATE of bug 1512959
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Upgrades
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard: beta
Depends On:
Blocks: 1122832 1533259
TreeView+ depends on / blocked
 
Reported: 2017-11-22 14:10 UTC by Lukas Zapletal
Modified: 2019-04-01 20:27 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-02 17:00:22 UTC


Attachments (Terms of Use)

Description Lukas Zapletal 2017-11-22 14:10:25 UTC
There is no upgrade path for pulp packages from client tools, looks like these are in conflict with packages from Satellite repo.

1) Install 6.2
2) Enable and install client tools like katello-agent
3) Perform upgrade according to our docs:

Package failure when sat6 6.2 client tools are installed:
                ----------
                ---> Package tfm-rubygem-unf_ext.x86_64 0:0.0.6-6.el7sat will be installed
                --> Finished Dependency Resolution
                Error: Package: python-pulp-agent-lib-2.8.7.15-1.el7sat.noarch (@rhel-7-server-satellite-6.2-rpms)
                                                  Requires: python-pulp-common = 2.8.7.15
                                                  Removing: python-pulp-common-2.8.7.15-1.el7sat.noarch (@rhel-7-server-satellite-6.2-rpms)
                                                                  python-pulp-common = 2.8.7.15-1.el7sat
                                                  Updated By: python-pulp-common-2.13.4.2-1.el7sat.noarch (rhel-server-7-satellite-6-beta-rpms)
                                                                  python-pulp-common = 2.13.4.2-1.el7sat
                **********************************************************************
                yum can be configured to try to resolve such errors by temporarily enabling
                disabled repos and searching for missing dependencies.
                To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf
                **********************************************************************
 
                Error: Package: python-pulp-agent-lib-2.8.7.15-1.el7sat.noarch (@rhel-7-server-satellite-6.2-rpms)
                                                  Requires: python-pulp-common = 2.8.7.15
                                                  Removing: python-pulp-common-2.8.7.15-1.el7sat.noarch (@rhel-7-server-satellite-6.2-rpms)
                                                                  python-pulp-common = 2.8.7.15-1.el7sat
                                                  Updated By: python-pulp-common-2.13.4.2-1.el7sat.noarch (rhel-server-7-satellite-6-beta-rpms)
                                                                  python-pulp-common = 2.13.4.2-1.el7sat
                You could try using --skip-broken to work around the problem
                You could try running: rpm -Va --nofiles --nodigest
    -------------
                Unblocked by removing the python-pulp-agent-lib

Comment 3 David Kaylor 2017-11-30 16:48:11 UTC
I ran into the same python-pulp-agent-lib dependency error because I had pulp-admin installed per https://access.redhat.com/solutions/1295653. Upgraded versions of both python-pulp-agent-lib and pulp-rpm-handlers are not available in the repo:

# yum repolist
Loaded plugins: product-id, search-disabled-repos, subscription-manager
repo id                                         repo name                                                                     status
rhel-7-server-rpms/7Server/x86_64               Red Hat Enterprise Linux 7 Server (RPMs)                                      17,716
rhel-server-7-satellite-6-beta-rpms/x86_64      Red Hat Satellite 6 Beta (for RHEL 7 Server) (RPMs)                              311
rhel-server-rhscl-7-rpms/7Server/x86_64         Red Hat Software Collections RPMs for Red Hat Enterprise Linux 7 Server        9,198
rhel7                                           RHEL 7 Server                                                                  4,986
rhel7-optional                                  RHEL 7 Server Optional                                                         4,554
repolist: 36,765
# yum list python-pulp-common
Loaded plugins: product-id, search-disabled-repos, subscription-manager
Installed Packages
python-pulp-common.noarch                           2.8.7.15-1.el7sat                            @rhel-7-server-satellite-6.2-rpms  
Available Packages
python-pulp-common.noarch                           2.13.4.2-1.el7sat                            rhel-server-7-satellite-6-beta-rpms
# yum list python-pulp-agent-lib
Loaded plugins: product-id, search-disabled-repos, subscription-manager
Installed Packages
python-pulp-agent-lib.noarch                           2.8.7.15-1.el7sat                           @rhel-7-server-satellite-6.2-rpms
# yum list pulp-rpm-handlers
Loaded plugins: product-id, search-disabled-repos, subscription-manager
Installed Packages
pulp-rpm-handlers.noarch                             2.8.7.18-1.el7sat                             @rhel-7-server-satellite-6.2-rpms

Comment 4 Ivan Necas 2018-01-02 17:00:22 UTC
Marking as duplicate of 1512959, which also mentions the workaround for the issue:

"""
Customers who upgrade from Satellite 6.2 to Satellite 6.3 must enable the satellite-tools repository to successfully perform the upgrade
"""

*** This bug has been marked as a duplicate of bug 1512959 ***


Note You need to log in before you can comment on or make changes to this bug.