Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516320 - Ad hoc Metrics for Nodes crashes
Summary: Ad hoc Metrics for Nodes crashes
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.10.0
Assignee: Yaacov Zamir
QA Contact: Einat Pacifici
URL:
Whiteboard:
: 1516702 (view as bug list)
Depends On:
Blocks: 1517946
TreeView+ depends on / blocked
 
Reported: 2017-11-22 13:15 UTC by Pavel Zagalsky
Modified: 2018-06-21 21:14 UTC (History)
9 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1517946 (view as bug list)
Environment:
Last Closed: 2018-06-21 21:14:24 UTC
Category: ---
Cloudforms Team: Container Management


Attachments (Terms of Use)
Ad hoc Metrics screenshot (deleted)
2017-11-22 13:15 UTC, Pavel Zagalsky
no flags Details
production.log (deleted)
2017-11-22 13:16 UTC, Pavel Zagalsky
no flags Details

Description Pavel Zagalsky 2017-11-22 13:15:28 UTC
Created attachment 1357504 [details]
Ad hoc Metrics screenshot

Description of problem:
Attempting to open Ad hoc Metrics for Nodes yields an error message

Version-Release number of selected component (if applicable):
5.9.0.x

How reproducible:
Always


Steps to Reproduce:
1. Navigate to Compute --> Containers --> Container Nodes
2. Select one of the nodes.
3. Select Monitoring --> Ad hoc Metrics

Actual results:
The screen appears with an error message

Expected results:
The screen should appear with Ad hoc Metrics

Additional info:
Attached production.log and a screenshot

Comment 2 Pavel Zagalsky 2017-11-22 13:16:11 UTC
Created attachment 1357505 [details]
production.log

Comment 3 Yaacov Zamir 2017-11-26 07:29:12 UTC
Submitted upstream:
Fix for Hawkualr   - https://github.com/ManageIQ/manageiq-ui-classic/pull/2824
Fix for Prometheus - Not yes a PR

Comment 4 Yaacov Zamir 2017-11-26 11:09:58 UTC
Submitted upstream:
Fix for Hawkualr   - https://github.com/ManageIQ/manageiq-ui-classic/pull/2824
Fix for Prometheus - https://github.com/ManageIQ/manageiq-ui-classic/pull/2826

Comment 8 Yaacov Zamir 2017-12-11 12:17:24 UTC
*** Bug 1516702 has been marked as a duplicate of this bug. ***

Comment 9 Shalom Naim 2017-12-31 12:15:32 UTC
I see that this issue occurs in version 5.8.3.0 as well, do we want to solve it?

Comment 13 Einat Pacifici 2018-06-21 12:08:47 UTC
Verified. Ad-Hoc metrics does not crash for Nodes.


Note You need to log in before you can comment on or make changes to this bug.