Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516308 - OSP11 -> OSP12 upgrade: packages get remove from compute nodes during upgrade even though UpgradeRemoveUnusedPackages is not set
Summary: OSP11 -> OSP12 upgrade: packages get remove from compute nodes during upgrade...
Keywords:
Status: CLOSED DUPLICATE of bug 1516210
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ga
: 12.0 (Pike)
Assignee: Marios Andreou
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-22 12:49 UTC by Marius Cornea
Modified: 2017-11-28 15:31 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-28 12:54:33 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 522540 None None None 2017-11-23 12:50:23 UTC
Launchpad 1734118 None None None 2017-11-23 12:49:58 UTC

Description Marius Cornea 2017-11-22 12:49:24 UTC
Description of problem:
OSP11 -> OSP12 upgrade: packages get remove from compute nodes during upgrade even though UpgradeRemoveUnusedPackages is not set. We can see the tasks while running a compute node upgrade:

TASK [Remove openstack-ceilometer-compute package if operator requests it] ********************************************************************************************************************************************************************
changed: [192.168.24.12]

TASK [Remove openstack-ceilometer-polling package if operator requests it] ********************************************************************************************************************************************************************
changed: [192.168.24.12]

TASK [Remove openstack-nova-compute package if operator requests it] **************************************************************************************************************************************************************************
changed: [192.168.24.12]

Checking the compute node after upgrade we can see that the rpms were removed during upgrade:

in /var/log/yum.log:
Nov 22 12:27:25 Erased: 1:openstack-ceilometer-compute-8.1.1-2.el7ost.noarch
Nov 22 12:27:28 Erased: 1:openstack-ceilometer-central-8.1.1-2.el7ost.noarch
Nov 22 12:27:28 Erased: 1:openstack-ceilometer-polling-8.1.1-2.el7ost.noarch
Nov 22 12:27:43 Erased: 1:openstack-nova-migration-15.0.7-3.el7ost.noarch
Nov 22 12:27:43 Erased: 1:openstack-nova-compute-15.0.7-3.el7ost.noarch
Nov 22 12:27:55 Installed: python2-pbr-3.1.1-1.el7ost.noarch

Note: the UpgradeRemoveUnusedPackages is not set so I expect no packages to be removed during upgrade

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-7.0.3-10.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy OSP11
2. Upgrade to OSP12

Actual results:
During compute nodes upgrade there are some packages getting removed from the computes even though the UpgradeRemoveUnusedPackages parameter which should control whether packages get removed during upgrade is not set.

Expected results:
Packages do not get removed by the upgrade workflow unless requested by the user.

Additional info:

Comment 1 Marios Andreou 2017-11-22 17:07:23 UTC
i can see what the problem is here ... the issue is in the code @ https://github.com/openstack/tripleo-common/blob/9f5e38e7d398c60af4d165943417dbde70639d53/tripleo_common/utils/config.py#L129


tasks that look like this:


144         - name: Remove openstack-ceilometer-polling package if operator requests it$
145           yum: name=openstack-ceilometer-polling state=removed$                
146           tags: step2$                                                         
147           ignore_errors: True$                                                 
148           when: {get_param: UpgradeRemoveUnusedPackages}$                      


end up like this:

- ignore_errors: true
  name: Remove openstack-ceilometer-compute package if operator requests it
  tags: step2
  when: step|int == 2
  yum: name=openstack-ceilometer-compute state=removed


i.e. the UpgradeRemoveUnusedPackages param is ignored. Will post something tomorrow. I also suspect this is related to https://bugzilla.redhat.com/show_bug.cgi?id=1516210#c1 but to be confirmed

Comment 5 Marios Andreou 2017-11-28 12:54:33 UTC

*** This bug has been marked as a duplicate of bug 1516210 ***


Note You need to log in before you can comment on or make changes to this bug.