Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516305 - [abrt] python-bugzilla-cli: main(): bugzilla:1108:main:RuntimeError: Unexpected action 'None'
Summary: [abrt] python-bugzilla-cli: main(): bugzilla:1108:main:RuntimeError: Unexpect...
Keywords:
Status: CLOSED DUPLICATE of bug 1513819
Alias: None
Product: Fedora
Classification: Fedora
Component: python-bugzilla
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:9af788bb157746b796428787721...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-22 12:43 UTC by Reverend Homer
Modified: 2018-05-01 17:44 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-22 12:49:04 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2017-11-22 12:43 UTC, Reverend Homer
no flags Details
File: cgroup (deleted)
2017-11-22 12:43 UTC, Reverend Homer
no flags Details
File: cpuinfo (deleted)
2017-11-22 12:43 UTC, Reverend Homer
no flags Details
File: environ (deleted)
2017-11-22 12:43 UTC, Reverend Homer
no flags Details
File: mountinfo (deleted)
2017-11-22 12:43 UTC, Reverend Homer
no flags Details
File: namespaces (deleted)
2017-11-22 12:43 UTC, Reverend Homer
no flags Details
File: open_fds (deleted)
2017-11-22 12:43 UTC, Reverend Homer
no flags Details

Description Reverend Homer 2017-11-22 12:43:24 UTC
Description of problem:
"bugzilla" crashed when I just typed "bugzilla" without any arguments

Version-Release number of selected component:
python-bugzilla-cli-2.1.0-2.fc27

Additional info:
reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 /usr/bin/bugzilla
crash_function: main
exception_type: RuntimeError
executable:     /usr/bin/bugzilla
kernel:         4.13.13-300.fc27.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
bugzilla:1108:main:RuntimeError: Unexpected action 'None'

Traceback (most recent call last):
  File "/usr/bin/bugzilla", line 1117, in <module>
    main()
  File "/usr/bin/bugzilla", line 1108, in main
    raise RuntimeError("Unexpected action '%s'" % action)
RuntimeError: Unexpected action 'None'

Local variables in innermost frame:
buglist: []
bz: <bugzilla.rhbugzilla.RHBugzilla object at 0x7f6e62b92ef0>
action: None
args: []
opt: Namespace(bugzilla='https://bugzilla.redhat.com/xmlrpc.cgi', bztype='auto', cache_credentials=True, command_name=None, cookiefile=None, debug=False, ensure_logged_in=False, login=False, password=None, sslverify=True, tokenfile=None, username=None, verbose=False)
parser: ArgumentParser(prog='bugzilla', usage=None, description=None, formatter_class=<class 'argparse.HelpFormatter'>, conflict_handler='error', add_help=True)
unittest_bz_instance: None

Potential duplicate: bug 1513819

Comment 1 Reverend Homer 2017-11-22 12:43:31 UTC
Created attachment 1357451 [details]
File: backtrace

Comment 2 Reverend Homer 2017-11-22 12:43:33 UTC
Created attachment 1357452 [details]
File: cgroup

Comment 3 Reverend Homer 2017-11-22 12:43:35 UTC
Created attachment 1357453 [details]
File: cpuinfo

Comment 4 Reverend Homer 2017-11-22 12:43:37 UTC
Created attachment 1357454 [details]
File: environ

Comment 5 Reverend Homer 2017-11-22 12:43:39 UTC
Created attachment 1357455 [details]
File: mountinfo

Comment 6 Reverend Homer 2017-11-22 12:43:41 UTC
Created attachment 1357456 [details]
File: namespaces

Comment 7 Reverend Homer 2017-11-22 12:43:42 UTC
Created attachment 1357457 [details]
File: open_fds

Comment 8 Reverend Homer 2017-11-22 12:49:04 UTC
Oops, looks like this is duplicate of #1513819, sorry!

*** This bug has been marked as a duplicate of bug 1513819 ***

Comment 9 Jan Vesely 2018-03-02 15:26:56 UTC
*** Bug 1551026 has been marked as a duplicate of this bug. ***

Comment 10 Prabhjot Singh 2018-05-01 17:44:01 UTC
*** Bug 1573567 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.