Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516288 - [GSS] heketi doesn't remove old pods
Summary: [GSS] heketi doesn't remove old pods
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: heketi
Version: rhgs-3.3
Hardware: x86_64
OS: Linux
urgent
high
Target Milestone: ---
: CNS 3.9
Assignee: Michael Adam
QA Contact: Rachael
URL:
Whiteboard:
Depends On:
Blocks: 1526414
TreeView+ depends on / blocked
 
Reported: 2017-11-22 12:20 UTC by Damian Wojsław
Modified: 2018-11-09 13:19 UTC (History)
10 users (show)

Fixed In Version: heketi-6.0.0-2.el7rhgs
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-05 03:08:10 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:0638 None None None 2018-04-05 03:09:27 UTC
Red Hat Bugzilla 1521027 None None None Never

Internal Links: 1521027

Description Damian Wojsław 2017-11-22 12:20:25 UTC
Description of problem:
After some time of operating openshift the internal database of storage differs from actual list of deployed storage. This sometimes leads to a situation where new deployments fail or get stuck, because the pvr can't be satisfied.

Version-Release number of selected component (if applicable):


How reproducible:
Run oc with gluster as backing storage for pods. Create and delete projects. After some time you should see difference between what's on storage and what heketi thinks is there. 

Steps to Reproduce:
1. install Openshift cluster with gluster as CRS
2. Run some project creations, deletions
3. Check volumes in OpenShift and in heketi

Actual results:
The number of volumes present in heketi and not in OpenShift is different.

Expected results:
The number should be the same, 

Additional info:
In next comments

Comment 14 errata-xmlrpc 2018-04-05 03:08:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:0638


Note You need to log in before you can comment on or make changes to this bug.