Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516264 - Unable to ping gateway ip in rhel7.4
Summary: Unable to ping gateway ip in rhel7.4
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: NetworkManager
Version: 7.4
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: rc
: ---
Assignee: sushil kulkarni
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-22 11:36 UTC by ramanjk
Modified: 2017-11-24 09:39 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-24 09:39:41 UTC


Attachments (Terms of Use)
commands output (deleted)
2017-11-22 11:36 UTC, ramanjk
no flags Details
hardware_info (deleted)
2017-11-22 13:05 UTC, ramanjk
no flags Details

Description ramanjk 2017-11-22 11:36:54 UTC
Created attachment 1357405 [details]
commands output

Description of problem:Unable to ping configured static gateway IP.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Installed rhel7.4 with dual boot on my HP 15-ay503tx model laptop.
2.Configured static ip's with nmcli and also traied with configuration files.
3.tested with ping of my both system ip and gateway ip..system ip pinging,But gateway is not pinagable

Actual results:Host unreachable when we ping the gateway ip


Expected results:gateway ip should get ping


Additional info:

Comment 2 Francesco Giudici 2017-11-22 12:21:11 UTC
Hi ramanjk,
  from the image you attached the NetworkManager configuration looks fine.
Also your route configuration looks fine.
I cannot see any NetworkManager misconfiguration here.

Are you sure your gateway is reachable and replies to ping?
Can you check if it replies to arp requests?

# arping -I enp2s0 172.25.0.250

thanks

Comment 3 ramanjk 2017-11-22 12:31:18 UTC
Hi sir, not getting any output for command..

Comment 4 ramanjk 2017-11-22 12:38:13 UTC
Hi sir, getting zero responses for above acommand.

Comment 5 ramanjk 2017-11-22 13:05:39 UTC
Created attachment 1357475 [details]
hardware_info

Hi,Please check the firmware of r8169 messages in the above attatchment for dmesg command...and also check with your analysis and update me asap.

Comment 6 Francesco Giudici 2017-11-22 13:30:35 UTC
(In reply to ramanjk from comment #4)
> Hi sir, getting zero responses for above acommand.
Hi ramanjk,
 so, it seems that 172.25.0.250 is not l2 reachable via interface enp2s0.

If you are sure everything is fine on the network setup I think you got it right: you issue is probably the support of your ethernet card (driver).

Not sure your hardware is supported in RHEL. Please check and if it is then contact your RHEL support and move the bug to a more appropriate component.
I'm pretty sure this is not related to NetworkManager.

Comment 7 ramanjk 2017-11-22 13:38:17 UTC
Hi,

So if there is no problem with network manager configuration,,,can you please loop to the concern person to resolve this issue,bcoz I am unable to get the exact issue..

Comment 8 Francesco Giudici 2017-11-22 15:24:09 UTC
(In reply to ramanjk from comment #7)
> Hi,
> 
> So if there is no problem with network manager configuration,,,can you
> please loop to the concern person to resolve this issue,bcoz I am unable to
> get the exact issue..

My guess is that your hardware is not supported.
I think bugzilla is not the right place to start with in this case, probably you may want to contact the Red Hat customer support. They should be able to provide you the answers and the help you may need.

Comment 9 Francesco Giudici 2017-11-24 09:39:41 UTC
There is no bug in NetworkManager here. As far as I can see there is no bug at all, the issue is that the hardware is not supported in RHEL.

Closing the bug, please reopen and move to a more appropriate component if needed.


Note You need to log in before you can comment on or make changes to this bug.