Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516263 - rhsone colonizer must take care of setting gluster bricks with selinux labels
Summary: rhsone colonizer must take care of setting gluster bricks with selinux labels
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gluster-colonizer
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: RHGS 3.3.1 Async
Assignee: Dustin Black
QA Contact: nchilaka
URL:
Whiteboard:
Depends On:
Blocks: 1542835
TreeView+ depends on / blocked
 
Reported: 2017-11-22 11:36 UTC by nchilaka
Modified: 2019-04-03 09:12 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-12 12:04:55 UTC


Attachments (Terms of Use)
bricks_now_have_selinux_labels (deleted)
2018-02-13 11:08 UTC, nchilaka
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:0477 normal SHIPPED_LIVE RHEA: new package: gluster-colonizer 2018-03-12 18:12:47 UTC

Description nchilaka 2017-11-22 11:36:30 UTC
Description of problem:
=====================
when we deploy gluster using rhsone-colonizer , we currently are not setting the right selinux labels. 
we need to do that as part of rhsone-colonizer


Version-Release number of selected component (if applicable):
====

How reproducible:


Steps to Reproduce:
1.after deploying gluster setup using colonizer check the bricks using ls -ldZ 

Actual results:
=========
no selinux labels are set on the bricks

Expected results:
=============
set the right selinux labels for bricks

Comment 2 Dustin Black 2017-12-11 18:57:45 UTC
Commit upstream to add Ansible plays to set selinux context of brick directories.

https://github.com/red-hat-storage/gone/commit/2abc8cc8bb97b191a8226e3cd5d5867124663291

Comment 3 nchilaka 2018-02-13 11:08:07 UTC
tested on colonizer-1.0.1-2, selinux labels are now being set by colonizer installer.
Attached is the screenshot .
hence moving to verified

Comment 4 nchilaka 2018-02-13 11:08:48 UTC
Created attachment 1395271 [details]
bricks_now_have_selinux_labels

Comment 8 errata-xmlrpc 2018-03-12 12:04:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:0477


Note You need to log in before you can comment on or make changes to this bug.