Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516218 - Review Request: perl-Devel-GlobalPhase - Detect perl's global phase on older perls
Summary: Review Request: perl-Devel-GlobalPhase - Detect perl's global phase on older ...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1516074
TreeView+ depends on / blocked
 
Reported: 2017-11-22 10:02 UTC by Jitka Plesnikova
Modified: 2017-11-27 09:22 UTC (History)
2 users (show)

Fixed In Version: perl-Devel-GlobalPhase-0.003000-1.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-27 09:22:39 UTC
ppisar: fedora-review+


Attachments (Terms of Use)

Description Jitka Plesnikova 2017-11-22 10:02:01 UTC
Spec URL: https://jplesnik.fedorapeople.org/perl-Devel-GlobalPhase/perl-Devel-GlobalPhase.spec
SRPM URL: https://jplesnik.fedorapeople.org/perl-Devel-GlobalPhase/perl-Devel-GlobalPhase-0.003000-1.fc28.src.rpm

Description:
This gives access to ${^GLOBAL_PHASE} in versions of perl that don't
provide it. The built in variable will be used if it is available.

Fedora Account System Username: jplesnik@redhat.com

Comment 1 Petr Pisar 2017-11-22 12:36:46 UTC
URL and Source0 addresses are Ok.
Source archive (SHA-256: 7169874ee3bef3d80b120a232550c16f28c330b8a368e47fa03cf88d2690ecd4) is original. Ok.
Summary verified from lib/Devel/GlobalPhase.pm. Ok.
Description verified from lib/Devel/GlobalPhase.pm. Ok.

TODO: Spell the "built in" as "built-in" adjective in the description.

License verified from README and lib/Devel/GlobalPhase.pm. Ok.
No XS code, noarch BuildArch is Ok.

TODO: Constrain `perl(threads)' dependency with `>= 1.07' (t/threads.t:15).
FIXME: Build-require `perl(lib)' (t/main.t:2).
TODO: Do not package META.json.

All tests pass. Ok.

$ rpmlint perl-Devel-GlobalPhase.spec ../SRPMS/perl-Devel-GlobalPhase-0.003000-1.fc28.src.rpm ../RPMS/noarch/perl-Devel-GlobalPhase-0.003000-1.fc28.noarch.rpm 
perl-Devel-GlobalPhase.src: W: spelling-error Summary(en_US) perls -> Perls, peels, perks
perl-Devel-GlobalPhase.noarch: W: spelling-error Summary(en_US) perls -> Perls, peels, perks
2 packages and 1 specfiles checked; 0 errors, 2 warnings.
rpmlint is Ok.

$ rpm -q -lv -p ../RPMS/noarch/perl-Devel-GlobalPhase-0.003000-1.fc28.noarch.rpm 
drwxr-xr-x    2 root    root                        0 Nov 22 13:30 /usr/share/doc/perl-Devel-GlobalPhase
-rw-r--r--    1 root    root                      960 Apr 15  2017 /usr/share/doc/perl-Devel-GlobalPhase/Changes
-rw-r--r--    1 root    root                     1281 Apr 15  2017 /usr/share/doc/perl-Devel-GlobalPhase/META.json
-rw-r--r--    1 root    root                     1577 Apr 15  2017 /usr/share/doc/perl-Devel-GlobalPhase/README
-rw-r--r--    1 root    root                     1892 Nov 22 13:30 /usr/share/man/man3/Devel::GlobalPhase.3pm.gz
drwxr-xr-x    2 root    root                        0 Nov 22 13:30 /usr/share/perl5/vendor_perl/Devel
-rw-r--r--    1 root    root                     5926 Apr 15  2017 /usr/share/perl5/vendor_perl/Devel/GlobalPhase.pm
File layout and permissions are Ok.

$ rpm -q --requires -p ../RPMS/noarch/perl-Devel-GlobalPhase-0.003000-1.fc28.noarch.rpm | sort -f | uniq -c
      1 perl(:MODULE_COMPAT_5.26.1)
      1 perl(base)
      1 perl(Exporter)
      1 perl(strict)
      1 perl(warnings)
      1 rpmlib(CompressedFileNames) <= 3.0.4-1
      1 rpmlib(FileDigests) <= 4.6.0-1
      1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
      1 rpmlib(PayloadIsXz) <= 5.2-1
Binary requires are Ok.

$ rpm -q --provides -p ../RPMS/noarch/perl-Devel-GlobalPhase-0.003000-1.fc28.noarch.rpm | sort -f | uniq -c
      1 perl(Devel::GlobalPhase) = 0.003000
      1 perl-Devel-GlobalPhase = 0.003000-1.fc28
Binary provides are Ok.

$ resolvedeps rawhide ../RPMS/noarch/perl-Devel-GlobalPhase-0.003000-1.fc28.noarch.rpm 
Binary dependencies resolvable. Ok.

Package builds in F28 (https://koji.fedoraproject.org/koji/taskinfo?taskID=23299623). Ok.

Otherwise the package is in line with Fedora and Perl packaging guidelines.

Please correct the `FIX' items and consider fixing the `TODO' items before building this package.
Resolution: Package APPROVED.

Comment 2 Patrick Uiterwijk 2017-11-24 15:17:27 UTC
(fedrepo-req-admin):  The Pagure repository was created at https://src.fedoraproject.org/rpms/perl-Devel-GlobalPhase

Comment 3 Jitka Plesnikova 2017-11-27 09:22:39 UTC
Thank you for the review and the repository.


Note You need to log in before you can comment on or make changes to this bug.