Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516202 - "openstack undercloud upgrade" failing with "__init__() got an unexpected keyword argument 'url'"
Summary: "openstack undercloud upgrade" failing with "__init__() got an unexpected key...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: 10.0 (Newton)
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: async
: 10.0 (Newton)
Assignee: Julie Pichon
QA Contact: Gurenko Alex
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-22 09:27 UTC by Sergii Mykhailushko
Modified: 2019-02-18 16:02 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-10 14:40:29 UTC
vchundur: needinfo+


Attachments (Terms of Use)

Description Sergii Mykhailushko 2017-11-22 09:27:10 UTC
- Description of problem:

When running undercloud upgrade (RHOSP10 minor update), it fails with the following message:

~~~
DEBUG os_client_config.config [ admin admin] Deferring keystone exception: __init__() got an unexpected keyword argument 'url'
INFO osc_lib.shell [ admin admin] command: undercloud upgrade -> tripleoclient.v1.undercloud.UpgradeUndercloud
DEBUG tripleoclient.v1.undercloud.UpgradeUndercloud [ admin admin] run(Namespace())
DEBUG tripleoclient.v1.undercloud.UpgradeUndercloud [ admin admin] take action(Namespace())
ERROR openstack [ admin admin] Command 'instack-install-undercloud' returned non-zero exit status 1
~~~

- Version-Release number of selected component (if applicable):

instack-5.0.0-1.el7ost.noarch
instack-undercloud-5.3.2-2.el7ost.noarch
openstack-tripleo-0.0.8-0.2.4de13b3git.el7ost.noarch
openstack-tripleo-common-5.4.4-1.el7ost.noarch
openstack-tripleo-heat-templates-5.3.3-1.el7ost.noarch
openstack-tripleo-image-elements-5.3.1-1.el7ost.noarch
openstack-tripleo-puppet-elements-5.3.2-1.el7ost.noarch
openstack-tripleo-ui-1.2.1-1.el7ost.noarch
openstack-tripleo-validations-5.1.2-1.el7ost.noarch
puppet-tripleo-5.6.4-2.el7ost.noarch
python-tripleoclient-5.4.3-1.el7ost.noarch

- How reproducible: 100%

- Steps to Reproduce:

1. update instack-undercloud openstack-puppet-modules openstack-tripleo-common python-tripleoclient
2. openstack --debug undercloud upgrade

- Actual results: upgrade fails with the above message

- Expected results: upgrade succeeds

Comment 4 David Hill 2017-11-22 15:08:12 UTC
Should we backport [1] to RHOSP 10 too ?

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1488471

Comment 11 Jose Luis Franco 2017-11-23 11:56:36 UTC
From what I could observe, the log /cases/01972240/x-text/01972240-2017-11-17-undercloud_upgrade.log contains the initial error. The first 'undercloud upgrade' failed with this error:

2017-11-17 16:29:46 - ^[[mNotice: /Firewall[999 drop all]: Dependency Keystone_user[zaqar] has failures: true^[[0m
2017-11-17 16:29:46 - ^[[mNotice: /Firewall[999 drop all]: Dependency Keystone_user[zaqar-websocket] has failures: true^[[0m
2017-11-17 16:29:46 - ^[[1;31mWarning: /Firewall[999 drop all]: Skipping because of failed dependencies^[[0m
2017-11-17 16:29:47 - ^[[mNotice: Finished catalog run in 3405.47 seconds^[[0m
+ rc=6
+ set -e
+ echo 'puppet apply exited with exit code 6'
puppet apply exited with exit code 6
+ '[' 6 '!=' 2 -a 6 '!=' 0 ']'
+ exit 6
[2017-11-17 16:29:52,317] (os-refresh-config) [ERROR] during configure phase. [Command '['dib-run-parts', '/usr/libexec/os-refresh-config/configure.d']' returned non-zero exit status 1]

[2017-11-17 16:29:52,317] (os-refresh-config) [ERROR] Aborting...
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 1256, in install
    _run_orc(instack_env)
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 1020, in _run_orc
    _run_live_command(args, instack_env, 'os-refresh-config')
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 519, in _run_live_command
    raise RuntimeError('%s failed. See log for details.' % name)
RuntimeError: os-refresh-config failed. See log for details.
Command 'instack-install-undercloud' returned non-zero exit status 1
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/cliff/app.py", line 387, in run_subcommand
    result = cmd.run(parsed_args)
  File "/usr/lib/python2.7/site-packages/osc_lib/command/command.py", line 41, in run
    return super(Command, self).run(parsed_args)
  File "/usr/lib/python2.7/site-packages/cliff/command.py", line 59, in run
    return self.take_action(parsed_args) or 0
  File "/usr/lib/python2.7/site-packages/tripleoclient/v1/undercloud.py", line 51, in take_action
    subprocess.check_call("instack-install-undercloud")
  File "/usr/lib64/python2.7/subprocess.py", line 542, in check_call
    raise CalledProcessError(retcode, cmd)
CalledProcessError: Command 'instack-install-undercloud' returned non-zero exit status 1

I found bugzilla describing a similar behavior, although in this case it was from RHOSP8 to RHOSP9: https://bugzilla.redhat.com/show_bug.cgi?id=1325702

Is the UC SSL enabled?

Comment 12 Vijay Chundury 2017-11-23 12:14:32 UTC
Edu,
I checked this bug this has nothing to do with DPDK deployment issues/perf or data path issues that my team is tasked to do.
It seems as you are trying to update with more computes it is failing and it is best upgrades DFG (perhaps) can help.

Comment 24 Edu Alcaniz 2017-11-26 06:28:23 UTC
We did a remote session with the customer 

- the second patch wasn't being applied, so we ran this one and it works: 88078b2.diff
- We found out that the undercloud upgrade was blocked by a proxy (error 504 was returned)
- We introspected the new nodes
- We ran overcloud deploy with the 2 new nodes
- Since the undercloud was updated and not the overcloud, we've hit this bug [1].
- We changed the following file and removed the include to add include ::ntpd
- We had a similar issue with ::sshd, but we weren't able to fix this because the class :sshd doesn't exist. It looks like it's been added in osp-tht 5.3.
- We agreed to reconvene Sunday afternoon (your time). I'll have the time to have a chat with a SME about this.

[1] https://access.redhat.com/solutions/3122581

Comment 32 Julie Pichon 2018-01-10 14:40:29 UTC
The bug happened in an environment after a lot of manual intervention and doesn't seem to occur in other contexts. We'll close this for now, although if it happens in other cases too we will want to revisit.


Note You need to log in before you can comment on or make changes to this bug.