Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516121 - There are some excess steps when deploying the HostedEngine.
Summary: There are some excess steps when deploying the HostedEngine.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: Hosted Engine
Version: ---
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ovirt-4.2.0
: ---
Assignee: Phillip Bailey
QA Contact: Yihui Zhao
URL:
Whiteboard:
: 1524148 1524372 (view as bug list)
Depends On:
Blocks: 1367457
TreeView+ depends on / blocked
 
Reported: 2017-11-22 05:41 UTC by Yihui Zhao
Modified: 2017-12-20 10:57 UTC (History)
14 users (show)

Fixed In Version: cockpit-ovirt-0.11.2-0.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-20 10:57:26 UTC
oVirt Team: Node
rule-engine: ovirt-4.2+
cshao: testing_ack+


Attachments (Terms of Use)
storage_path.png (deleted)
2017-11-22 05:41 UTC, Yihui Zhao
no flags Details
FQDN.png (deleted)
2017-11-22 05:44 UTC, Yihui Zhao
no flags Details
FQDN.png (deleted)
2017-12-06 06:22 UTC, Yihui Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 84728 master MERGED wizard: Correct keys for bridge interface & name 2017-11-28 01:54:07 UTC
oVirt gerrit 84736 master MERGED wizard: Use storageDomainConnection key for NFS 2017-11-28 01:54:35 UTC
oVirt gerrit 84745 master MERGED wizard: Correct keys for root and admin passwords 2017-11-28 01:55:00 UTC
oVirt gerrit 84768 ovirt-4.2 MERGED wizard: Correct keys for bridge interface & name 2017-11-28 01:54:20 UTC
oVirt gerrit 84769 ovirt-4.2 MERGED wizard: Use storageDomainConnection key for NFS 2017-11-28 01:54:48 UTC
oVirt gerrit 84770 ovirt-4.2 MERGED wizard: Correct keys for root and admin passwords 2017-11-28 01:55:13 UTC
oVirt gerrit 85166 master MERGED wizard: Capture VM host name and domain name 2017-12-12 20:35:37 UTC
oVirt gerrit 85285 master MERGED wizard: Correct answer file key for root password 2017-12-12 21:03:54 UTC
oVirt gerrit 85359 ovirt-4.2 MERGED wizard: Capture VM host name and domain name 2017-12-12 20:35:51 UTC
oVirt gerrit 85360 ovirt-4.2 MERGED wizard: Correct answer file key for root password 2017-12-12 21:04:07 UTC

Description Yihui Zhao 2017-11-22 05:41:53 UTC
Created attachment 1357238 [details]
storage_path.png

Description of problem:
There are some excess steps when deploying the HostedEngine via cockpit

Version-Release number of selected component (if applicable):
rhvh-4.2.0.4-0.20171117.0+1
cockpit-ovirt-dashboard-0.11.1-0.4.el7ev.noarch
cockpit-ws-155-1.el7.x86_64
cockpit-dashboard-155-1.el7.x86_64
cockpit-system-155-1.el7.noarch
cockpit-storaged-155-1.el7.noarch
cockpit-bridge-155-1.el7.x86_64
cockpit-155-1.el7.x86_64
rhvm-appliance-4.2-20171102.0.el7.noarch
ovirt-hosted-engine-setup-2.2.0-0.4.master.git0b67c21.el7ev.noarch

How reproducible:
100%


Steps to Reproduce:
1. Clean install rhvh-4.2.0.4-0.20171117.0+1
2. Deploy HostedEngine for some configs  via Cockpit


Actual results:
After step2, Cockpit also need to provide some steps to do some configs, like input the storage path, engine FQDN, root password, engine password, etc. 



Expected results:
After step2, Cockpit shouldn't need to some excess steps to input the storage path, engine FQDN, root password, engine password, etc.


Additional info:
The upstream also has the same problem.
The upstream build:
ovirt-node-ng-4.2.0-0.20171116.0+1
cockpit-156-1.el7.centos.x86_64
cockpit-bridge-156-1.el7.centos.x86_64
cockpit-ws-156-1.el7.centos.x86_64
cockpit-networkmanager-156-1.el7.centos.noarch
cockpit-dashboard-156-1.el7.centos.x86_64
cockpit-ovirt-dashboard-0.11.1-0.4.el7.centos.noarch
cockpit-system-156-1.el7.centos.noarch
cockpit-storaged-156-1.el7.centos.noarch
ovirt-hosted-engine-setup-2.2.0-0.0.master.20171027094933.git2f7cf9a.el7.centos.noarch
rhvm-appliance-4.2-20171102.0.el7.noarch

Comment 1 Yihui Zhao 2017-11-22 05:44:15 UTC
Created attachment 1357239 [details]
FQDN.png

Comment 2 Yihui Zhao 2017-12-06 06:22:33 UTC
Created attachment 1363511 [details]
FQDN.png

Comment 3 Yihui Zhao 2017-12-06 06:23:36 UTC
Also can meet this issue, need to input the FQDN and root password again.

Version-Release number of selected component (if applicable):
rhvh-4.2.0.5-0.20171123.0+1
rhvm-appliance-4.2-20171102.0.el7.noarch
cockpit-ovirt-dashboard-0.11.1-0.6.el7ev.noarch


Steps to Reproduce:
1. Install rhvh-4.2.0.5-0.20171123.0+1
2. Upgrade the cockpit-ovirt-dashboard pkg, restart cockpit
3. Deploy HostedEngine

Actual results:
After step3, Cockpit also need to provide some steps to do some configs, like input engine FQDN, root password.

Additional:
Created attachment 1363511 [details]:
https://bugzilla.redhat.com/attachment.cgi?id=1363511

Comment 4 Phillip Bailey 2017-12-11 02:07:47 UTC
*** Bug 1524148 has been marked as a duplicate of this bug. ***

Comment 5 Phillip Bailey 2017-12-11 11:37:06 UTC
*** Bug 1524372 has been marked as a duplicate of this bug. ***

Comment 6 Yihui Zhao 2017-12-14 11:26:37 UTC
The issue don't occur.

Test version:
cockpit-ovirt-dashboard-0.11.2-0.1.el7ev.noarch
rhvh-4.2.0.6-0.20171213.0+1
rhvm-appliance-4.2-20171207.0.el7.noarch

Test steps:
1. Deploy HostedEngine via cockpit


Actual result:

There are no excess steps when deploying HostedEngine.


So, change the bug's status to verified.

Comment 7 Sandro Bonazzola 2017-12-20 10:57:26 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.