Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516113 - Deploy the HostedEngine failed with the default CPU type
Summary: Deploy the HostedEngine failed with the default CPU type
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: Hosted Engine
Version: ---
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ovirt-4.2.0
: ---
Assignee: Phillip Bailey
QA Contact: Yihui Zhao
URL:
Whiteboard:
: 1519732 1524132 1524170 (view as bug list)
Depends On:
Blocks: 1367457
TreeView+ depends on / blocked
 
Reported: 2017-11-22 05:19 UTC by Yihui Zhao
Modified: 2017-12-20 11:12 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-20 11:12:04 UTC
oVirt Team: Node
rule-engine: ovirt-4.2+
rule-engine: blocker+
cshao: testing_ack+


Attachments (Terms of Use)
cockpit_he.png (deleted)
2017-11-22 05:19 UTC, Yihui Zhao
no flags Details
ovirt-hosted-engine-setup.log (deleted)
2017-11-22 05:26 UTC, Yihui Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 84521 master MERGED wizard: Correct CPU type-related HE deployment failure 2017-11-28 01:52:21 UTC
oVirt gerrit 84766 ovirt-4.2 MERGED wizard: Correct CPU type-related HE deployment failure 2017-11-28 01:52:33 UTC
oVirt gerrit 84895 master MERGED wizard: Handle CPU types not supported by setup 2017-11-30 21:16:10 UTC
oVirt gerrit 84976 ovirt-4.2 MERGED wizard: Handle CPU types not supported by setup 2017-11-30 21:16:25 UTC

Description Yihui Zhao 2017-11-22 05:19:30 UTC
Created attachment 1357236 [details]
cockpit_he.png

Description of problem:
Deploy the HostedEngine failed with the default CPU type.


Version-Release number of selected component (if applicable):
rhvh-4.2.0.4-0.20171117.0+1
cockpit-ovirt-dashboard-0.11.1-0.4.el7ev.noarch
cockpit-ws-155-1.el7.x86_64
cockpit-dashboard-155-1.el7.x86_64
cockpit-system-155-1.el7.noarch
cockpit-storaged-155-1.el7.noarch
cockpit-bridge-155-1.el7.x86_64
cockpit-155-1.el7.x86_64
rhvm-appliance-4.2-20171102.0.el7.noarch
ovirt-hosted-engine-setup-2.2.0-0.4.master.git0b67c21.el7ev.noarch

How reproducible:
100%


Steps to Reproduce:
1. Clean install rhvh-4.2.0.4-0.20171117.0+1
2. Deploy HostedEngine for some configs  via Cockpit


Actual results:
After step2, HostedEngine deployment is failed with the default CPU type.
It shows:

The following CPU types are supported by this host:
- model_SandyBridge: Intel SandyBridge Family
- model_Westmere: Intel Westmere Family
- model_Nehalem: Intel Nehalem Family
- model_Penryn: Intel Penryn Family
- model_Conroe: Intel Conroe Family
Log file is located at /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20171121170054-srlctr.log

 Failed to execute stage 'Environment customization': Invalid CPU type specified: IvyBridge
 Hosted Engine deployment failed



Expected results:
After step2, deploy hostedengine successfully without any errors.

Additional info:
The upstream also has the same problem.
The upstream build:
ovirt-node-ng-4.2.0-0.20171116.0+1
cockpit-156-1.el7.centos.x86_64
cockpit-bridge-156-1.el7.centos.x86_64
cockpit-ws-156-1.el7.centos.x86_64
cockpit-networkmanager-156-1.el7.centos.noarch
cockpit-dashboard-156-1.el7.centos.x86_64
cockpit-ovirt-dashboard-0.11.1-0.4.el7.centos.noarch
cockpit-system-156-1.el7.centos.noarch
cockpit-storaged-156-1.el7.centos.noarch
ovirt-hosted-engine-setup-2.2.0-0.0.master.20171027094933.git2f7cf9a.el7.centos.noarch
rhvm-appliance-4.2-20171102.0.el7.noarch

Error info:
The following CPU types are supported by this host:
- model_Haswell-noTSX: Intel Haswell-noTSX Family
- model_SandyBridge: Intel SandyBridge Family
- model_Westmere: Intel Westmere Family
- model_Nehalem: Intel Nehalem Family
- model_Penryn: Intel Penryn Family
- model_Conroe: Intel Conroe Family
Log file is located at /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20171121175522-rr2dyj.log

Failed to execute stage 'Environment customization': Invalid CPU type specified: Haswell-noTSX
 Hosted Engine deployment failed

Comment 1 Yihui Zhao 2017-11-22 05:26:09 UTC
Created attachment 1357237 [details]
ovirt-hosted-engine-setup.log

Comment 2 Yaniv Kaul 2017-11-22 07:04:24 UTC
Is this using the new Ansible based flow or the old flow?

Comment 3 Yihui Zhao 2017-11-22 08:07:22 UTC
(In reply to Yaniv Kaul from comment #2)
> Is this using the new Ansible based flow or the old flow?

New Ansible based flow.

Comment 4 Phillip Bailey 2017-11-22 13:36:56 UTC
(In reply to Yaniv Kaul from comment #2)
> Is this using the new Ansible based flow or the old flow?

The current build of the wizard is actually using the old flow.

Comment 5 Red Hat Bugzilla Rules Engine 2017-11-23 11:33:47 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 6 Yihui Zhao 2017-12-07 02:45:35 UTC
*** Bug 1519732 has been marked as a duplicate of this bug. ***

Comment 7 Phillip Bailey 2017-12-11 02:10:01 UTC
*** Bug 1524170 has been marked as a duplicate of this bug. ***

Comment 8 Nikolai Sednev 2017-12-11 09:58:29 UTC
*** Bug 1524132 has been marked as a duplicate of this bug. ***

Comment 9 Yihui Zhao 2017-12-13 02:17:04 UTC
Don't occur this issue.

Test version:
rhvh-4.2.0.5-0.20171207.0+1
cockpit-ovirt-dashboard-0.11.1-0.6.el7ev.noarch
ovirt-hosted-engine-setup-2.2.0-2.el7ev.noarch
ovirt-hosted-engine-ha-2.2.0-1.el7ev.noarch
rhvm-appliance-4.2-20171207.0.el7.noarch

Test steps:
1. Deploy HE via cockpit

Test results:
Deploy the HostedEngine successfully with the default CPU type.


So, change the bug's status to verified.

Comment 10 Sandro Bonazzola 2017-12-20 11:12:04 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.