Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1516006 - An issue of connecting openstack cinder to hpe storevirtual block storage.
Summary: An issue of connecting openstack cinder to hpe storevirtual block storage.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder
Version: 10.0 (Newton)
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
: ---
Assignee: Eric Harney
QA Contact: Avi Avraham
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-21 19:08 UTC by ByoungHee Lee
Modified: 2017-11-21 23:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-21 23:48:34 UTC


Attachments (Terms of Use)
HPE StoreVirtual Storage Documents. (deleted)
2017-11-21 19:08 UTC, ByoungHee Lee
no flags Details

Description ByoungHee Lee 2017-11-21 19:08:34 UTC
Created attachment 1356944 [details]
HPE StoreVirtual Storage Documents.

Description of problem:
- According to the HPE storagevirtual storage documents, I installed python-lefthandclient-2.1.0 client module and configure the /etc/cinder/cinder.conf. and I restarted cinder related components but it didn't work well. 

Steps to Reproduce:
1. I installed python-lefthandclient-2.1.0 client module as follows. 
scp -r pip-9.0.1/ python-lefthandclient-2.1.0/ setuptools-7.0/ heat-admin@10.252.2.27:/home/heat-admin/
cd /home/heat-admin/pip-9.0.1/
sudo python setup.py install
cd /home/heat-admin/python-lefthandclient-2.1.0/
sudo pip install .

2. I configured /etc/cinder/cinder.conf
default_volume_type = tripleo_ceph
enabled_backends = tripleo_ceph,lefthand-rest
[lefthand-rest]
volume_driver=cinder.volume.drivers.hpe.hpe_lefthand_iscsi.HPELeftHandISCSIDriver
volume_backend_name=lefthand-rest
hpelefthand_api_url=https://10.252.0.247:8081/lhos
hpelefthand_username=optus
hpelefthand_password=optus123
hpelefthand_clustername=lefthandLargeCluster
image_volume_cache_enabled = True

3. I restared cinder components
- systemctl restart openstack-cinder-api on each controller
- systemctl restart openstack-cinder-schduler on each controller
- pcs resource restart openstack-cinder-volume on one controller


Actual results:
- At the first time, state of cinder-volume was up, but it was getting down after 20~30 secondes. 
+------------------+-------------------------+------+---------+-------+----------------------------+-----------------+
| Binary           | Host                    | Zone | Status  | State | Updated_at                 | Disabled Reason |
+------------------+-------------------------+------+---------+-------+----------------------------+-----------------+
| cinder-scheduler | hostgroup               | nova | enabled | up    | 2017-11-21T10:44:14.000000 | -               |
| cinder-volume    | hostgroup@lefthand-rest | nova | enabled | down  | 2017-11-21T10:13:37.000000 | -               |
| cinder-volume    | hostgroup@tripleo_ceph  | nova | enabled | up    | 2017-11-21T10:44:08.000000 | -               |
+------------------+-------------------------+------+---------+-------+----------------------------+-----------------+

- Error mesages as follows : 
2017-11-21 17:48:55.284 670389 INFO cinder.volume.manager [req-fa7f43e7-a660-479f-9df6-4ff296b02222 - - - - -] Initializing RPC dependent components of volume driver RBDDriver (1.2.0)
2017-11-21 17:48:55.295 670565 INFO cinder.volume.manager [req-0ff180a3-b348-4825-b521-72772c464a39 - - - - -] Initializing RPC dependent components of volume driver HPELeftHandISCSIDriver (2.0.10)
2017-11-21 17:48:55.296 670565 ERROR cinder.utils [req-0ff180a3-b348-4825-b521-72772c464a39 - - - - -] Volume driver HPELeftHandISCSIDriver not initialized
2017-11-21 17:48:55.296 670565 ERROR cinder.volume.manager [req-0ff180a3-b348-4825-b521-72772c464a39 - - - - -] Cannot complete RPC initialization because driver isn't initialized properly.
2017-11-21 17:48:55.343 670389 INFO cinder.volume.manager [req-fa7f43e7-a660-479f-9df6-4ff296b02222 - - - - -] Driver post RPC initialization completed successfully.
2017-11-21 17:49:05.298 670565 ERROR cinder.service [-] Manager for service cinder-volume hostgroup@lefthand-rest is reporting problems, not sending heartbeat. Service will appear "down".
2017-11-21 17:49:15.304 670565 ERROR cinder.service [-] Manager for service cinder-volume hostgroup@lefthand-rest is reporting problems, not sending heartbeat. Service will appear "down".

Comment 1 ByoungHee Lee 2017-11-21 23:47:20 UTC
It's done
The problem was hpelefthand_clustername parameter name wrong.

Thanks


Note You need to log in before you can comment on or make changes to this bug.