Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515969 - Ceilometer can't find nova instance because of name differences [NEEDINFO]
Summary: Ceilometer can't find nova instance because of name differences
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z7
: 10.0 (Newton)
Assignee: Pradeep Kilambi
QA Contact: Sasha Smolyak
URL:
Whiteboard:
: 1540052 (view as bug list)
Depends On: 1483456
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-21 17:22 UTC by Pradeep Kilambi
Modified: 2018-04-10 17:22 UTC (History)
30 users (show)

Fixed In Version: openstack-tripleo-heat-templates-5.3.3-3.el7ost, puppet-ceilometer-9.5.0-3.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, Ceilometer would not set the hostname in its configuration file, and used the default detected one. Consequently, in certain cases, Nova would override the default detected hostname with a custom hostname which would not match the Ceilometer auto-detected one. This would leave Ceilometer unable to poll for Nova instances statistics. With this update, Ceilometer now sets the same hostname that Nova sets. As a result, Ceilometer is now able to poll Nova instances correctly.
Clone Of: 1483456
Environment:
Last Closed: 2018-02-27 16:50:40 UTC
mlopes: needinfo? (pkilambi)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 521868 None None None 2017-11-21 17:25:38 UTC
OpenStack gerrit 521948 None None None 2017-11-21 17:24:57 UTC
Red Hat Knowledge Base (Solution) 3198662 None None None 2017-11-21 17:22:14 UTC
Red Hat Product Errata RHBA-2018:0364 normal SHIPPED_LIVE Red Hat OpenStack Platform 10.0 director Bug Fix Advisory 2018-02-27 21:51:12 UTC

Comment 6 Meiyan Zheng 2018-02-09 01:10:46 UTC
*** Bug 1540052 has been marked as a duplicate of this bug. ***

Comment 10 errata-xmlrpc 2018-02-27 16:50:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0364


Note You need to log in before you can comment on or make changes to this bug.