Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515935 - Hard to tell exit code and OOM status of containers when another process deletes pods
Summary: Hard to tell exit code and OOM status of containers when another process dele...
Keywords:
Status: CLOSED DUPLICATE of bug 1431824
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Pod
Version: unspecified
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: ---
Assignee: Seth Jennings
QA Contact: DeShuai Ma
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-21 16:21 UTC by Jim Minter
Modified: 2018-01-16 21:11 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-16 21:11:16 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1431824 None None None Never

Internal Links: 1431824

Description Jim Minter 2017-11-21 16:21:28 UTC
It's hard to tell the exit status (exit code, OOM status) of a container when it exits due to another process deleting the pod.

This was seen in a customer issue where a child process (gradle build) in a Jenkins slave pod was killed by the OOM killer, and the Jenkins master then deleted the pod before it exited naturally.

Had the pod exited naturally, the reason: OOMKilled and exit code would have been visible in the pod status.

Adding kubernetes Events for all container lifecycle events, including exit code and OOM indication would have helped customer and Red Hat to diagnose the issue faster.

https://github.com/kubernetes/kubernetes/pull/45682 would be a foundation for this work, but would need to be further extended to make the OOM indication visible.

Comment 6 Seth Jennings 2018-01-16 21:11:16 UTC
This is a feature request. Duping to the RFE.

*** This bug has been marked as a duplicate of bug 1431824 ***


Note You need to log in before you can comment on or make changes to this bug.