Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515919 - 'dnf update' does not update pkgconf due to missing i686 rpms
Summary: 'dnf update' does not update pkgconf due to missing i686 rpms
Keywords:
Status: CLOSED DUPLICATE of bug 1512799
Alias: None
Product: Fedora
Classification: Fedora
Component: pkgconf
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Neal Gompa
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-21 15:41 UTC by Satish Balay
Modified: 2017-11-21 17:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-21 17:37:30 UTC


Attachments (Terms of Use)

Description Satish Balay 2017-11-21 15:41:45 UTC
Description of problem:

'dnf update' does not update pkgconf due to missing i686 rpms

Version-Release number of selected component (if applicable):
pkgconf-1.3.9-1.fc27.i686
pkgconf-pkg-config-1.3.9-1.fc27.i686
pkgconf-1.3.10-1.fc27.x86_64

etc

How reproducible:

Always
Steps to Reproduce:
1. Have pkgconf-1.3.9-1.fc27.i686 and pkgconf-1.3.9-1.fc27.x86_64 installed
[similarly pkgconf-pkg-config-1.3.9-1.fc27.i686 and pkgconf-pkg-config-1.3.9-1.fc27.x86_64
2. run 'dnf update'
3.

Actual results:

[root@asterix ~]# yum update
Last metadata expiration check: 0:00:00 ago on Tue 21 Nov 2017 09:19:11 AM CST.
Dependencies resolved.

 Problem 1: package pkgconf-1.3.9-1.fc27.i686 requires libpkgconf(x86-32) = 1.3.9-1.fc27, but none of the providers can be installed
  - cannot install both libpkgconf-1.3.10-1.fc27.i686 and libpkgconf-1.3.9-1.fc27.i686
  - cannot install both libpkgconf-1.3.9-1.fc27.i686 and libpkgconf-1.3.10-1.fc27.i686
  - cannot install the best update candidate for package pkgconf-1.3.9-1.fc27.i686
  - cannot install the best update candidate for package libpkgconf-1.3.9-1.fc27.i686
 Problem 2: package pkgconf-pkg-config-1.3.9-1.fc27.i686 requires pkgconf-m4 = 1.3.9-1.fc27, but none of the providers can be installed
  - cannot install both pkgconf-m4-1.3.10-1.fc27.noarch and pkgconf-m4-1.3.9-1.fc27.noarch
  - cannot install both pkgconf-m4-1.3.9-1.fc27.noarch and pkgconf-m4-1.3.10-1.fc27.noarch
  - cannot install the best update candidate for package pkgconf-pkg-config-1.3.9-1.fc27.i686
  - cannot install the best update candidate for package pkgconf-m4-1.3.9-1.fc27.noarch
 Problem 3: problem with installed package pkgconf-1.3.9-1.fc27.i686
  - pkgconf-1.3.9-1.fc27.i686 has inferior architecture
  - cannot install both pkgconf-1.3.10-1.fc27.x86_64 and pkgconf-1.3.9-1.fc27.x86_64
  - cannot install both pkgconf-1.3.9-1.fc27.x86_64 and pkgconf-1.3.10-1.fc27.x86_64
  - cannot install the best update candidate for package pkgconf-1.3.9-1.fc27.x86_64
 Problem 4: package libpng-devel-2:1.6.31-1.fc27.i686 requires pkgconfig(x86-32), but none of the providers can be installed
  - pkgconf-pkg-config-1.3.9-1.fc27.i686 has inferior architecture
  - cannot install both pkgconf-pkg-config-1.3.10-1.fc27.x86_64 and pkgconf-pkg-config-1.3.9-1.fc27.x86_64
  - cannot install both pkgconf-pkg-config-1.3.9-1.fc27.x86_64 and pkgconf-pkg-config-1.3.10-1.fc27.x86_64
  - cannot install the best update candidate for package pkgconf-pkg-config-1.3.9-1.fc27.x86_64
  - cannot install the best update candidate for package libpng-devel-2:1.6.31-1.fc27.i686
 Problem 5: problem with installed package pkgconf-pkg-config-1.3.9-1.fc27.i686
  - package pkgconf-pkg-config-1.3.9-1.fc27.i686 requires pkgconf(x86-32) = 1.3.9-1.fc27, but none of the providers can be installed
  - package pkgconf-1.3.9-1.fc27.i686 requires libpkgconf(x86-32) = 1.3.9-1.fc27, but none of the providers can be installed
  - libpkgconf-1.3.9-1.fc27.i686 has inferior architecture
  - cannot install both libpkgconf-1.3.10-1.fc27.x86_64 and libpkgconf-1.3.9-1.fc27.x86_64
  - cannot install both libpkgconf-1.3.9-1.fc27.x86_64 and libpkgconf-1.3.10-1.fc27.x86_64
  - cannot install the best update candidate for package libpkgconf-1.3.9-1.fc27.x86_64
================================================================================
 Package                  Arch         Version              Repository     Size
================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 libpkgconf               i686         1.3.10-1.fc27        updates        32 k
 libpkgconf               x86_64       1.3.10-1.fc27        updates        31 k
 pkgconf                  x86_64       1.3.10-1.fc27        updates        31 k
 pkgconf-m4               noarch       1.3.10-1.fc27        updates        13 k
 pkgconf-pkg-config       x86_64       1.3.10-1.fc27        updates        13 k

Transaction Summary
================================================================================
Skip  5 Packages

Nothing to do.
Complete!


Expected results:

Clean update to pkgconf-1.3.10-1.fc27

Additional info:

Manually downloading the following packages - and adding them to the dnf transaction gets the update going

pkgconf-1.3.10-1.fc27.i686.rpm
pkgconf-pkg-config-1.3.10-1.fc27.i686.rpm

Comment 1 Igor Gnatenko 2017-11-21 17:37:30 UTC

*** This bug has been marked as a duplicate of bug 1512799 ***


Note You need to log in before you can comment on or make changes to this bug.