Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 151591 - snd_powermac modul is not configured - powerbook g4
Summary: snd_powermac modul is not configured - powerbook g4
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kudzu
Version: 4
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: FC4Target
TreeView+ depends on / blocked
 
Reported: 2005-03-20 14:19 UTC by shrek-m
Modified: 2014-03-17 02:52 UTC (History)
3 users (show)

Fixed In Version: 1.1.114-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-27 17:14:24 UTC


Attachments (Terms of Use)

Description shrek-m 2005-03-20 14:19:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.7.6) Gecko/20050308 Firefox/1.0.1 Fedora/1.0.1-5

Description of problem:
clean fresh install FC4T1 on a powerbook g4 12"
the soundcard is not configured properly while installation and later.



Version-Release number of selected component (if applicable):
fc4t1

How reproducible:
Always

Steps to Reproduce:
1. clean fresh install (text mode)
2. clicking blindely through firstboot (not really readable)
3. kudzu
4. system-config-soundcard
  

Actual Results:  the entries in hwconf are ok but no sound.

execude `modprobe snd_powermac`
and the sound is ok.
i am lazy, i add it in  /etc/rc.local
and all is ok after reboot.

Expected Results:  sound should work.

Additional info:

----1----
# grep MACIO -3 /etc/sysconfig/hwconf
desc: "Macintosh mouse button emulation"
-
class: AUDIO
bus: MACIO
detached: 0
driver: snd_powermac
desc: "Apple Computer Inc.|PowerMac Sound"
----/1----

----2----
# cat /etc/modprobe.conf
alias eth0 sungem
alias usb-controller ehci-hcd
alias usb-controller1 ohci-hcd
alias ieee1394-controller ohci1394
----/2----

Comment 1 Bill Nottingham 2005-04-19 15:03:13 UTC
*** Bug 155191 has been marked as a duplicate of this bug. ***

Comment 2 Bill Nottingham 2005-04-23 01:07:31 UTC
If you remove /etc/sysconfig/hwconf, and run 'kudzu -q', does it configure it?

Comment 3 Bill Nottingham 2005-04-25 22:17:09 UTC
Never mind.

Fixed in 0.1.114-1.

Comment 4 shrek-m 2005-04-27 11:21:59 UTC
sorry, there is nothing what is configured now correctly.

# yum -d0 list kudzu
Installed Packages
kudzu.ppc                                1.1.114-1              installed

# mv /etc/sysconfig/hwconf .
# kudzu
# kudzu -q
#



# LANG=C ls /etc/sysconfig/hw*
ls: /etc/sysconfig/hw*: No such file or directory

ok, after rebooting there is a hwconfig with exactly the same class:AUDIO
but nothing in modprobe.conf and no sound.

Comment 5 Bill Nottingham 2005-04-27 15:23:38 UTC
Following those steps on my powermac G4, it works for me:

# rm /etc/sysconfig/hwconf
# kudzu
# cat /etc/modprobe.conf
alias eth0 sungem
alias usb-controller ohci-hcd
alias ieee1394-controller ohci1394
alias snd-card-0 snd-powermac
options snd-card-0 index=0
options snd-powermac index=0
remove snd-powermac { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-powermac


Comment 6 shrek-m 2005-04-27 17:14:24 UTC
sorry, it seems that
 # mv /etc/sysconfig/hwconf .
was the culprit.
 # mv hwconf hwconf-old
and following once again your steps are ok now.

thanks.


Note You need to log in before you can comment on or make changes to this bug.