Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515893 - [RFE] Add switch to completely remove capsules
Summary: [RFE] Add switch to completely remove capsules
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Satellite Clone
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: John Mitsch
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: 1533259
TreeView+ depends on / blocked
 
Reported: 2017-11-21 14:51 UTC by Tomer Brisker
Modified: 2019-04-12 15:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-31 14:49:33 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3338321 None None None 2018-01-30 16:17:57 UTC

Description Tomer Brisker 2017-11-21 14:51:44 UTC
Currently, we disable capsules during the clone by disabling tftp,dhcp and dns and disassociating them from LCEs. 
When using the clone tool for testing purposes (e.g. during Beta testing), it can be useful to completely remove all capsules so that the testing clone isn't at risk of communication with production capsules due to unexpected behavior or human error.

Comment 2 John Mitsch 2017-11-28 15:27:11 UTC
upstream issue here: https://github.com/RedHatSatellite/satellite-clone/issues/280

Comment 6 John Mitsch 2018-01-30 14:12:58 UTC
Satellite doesn't support force deleting of capsules, so validations will prevent deleting a capsule on a cloned machine. There isn't a ton we can do about that in satellite-clone without causing issues elsewhere. Currently, to remove a capsule, you must remove any associations that will prevent it from being deleted.

Here are some steps that others have found helpful (some steps may not apply to your environment):

- for remote execution, go to administer->settings->remote execution and ensure that `remote_execution_without_proxy` is set to No/False
- then for every subnet, on the remote execution tab remove all capsules, and also on the capsules tab set all the dropdowns to empty
- for all domains set the dns capsule to empty
- for puppet/puppetca - on hosts page, select all hosts, choose all hosts not only on this page, and from the dropdown choose "change puppetmaster" and set it to none, and the same for puppet ca

After this, you should be able to delete a capsule.

If you run into trouble with these steps or still can't delete a capsule on a clone, please comment and we can debug further.

Comment 7 John Mitsch 2018-01-30 16:17:58 UTC
Added a KCS solution regarding this issue

Comment 8 Brad Buckingham 2018-01-31 14:49:33 UTC
At this time, there are no additional code changes planned; therefore, I am going to close the bugzilla.  If there are any concerns, please feel free to re-open with additional details.

The referenced KCS is intended to provide the steps the user may perform to enable them to remove the capsule.


Note You need to log in before you can comment on or make changes to this bug.