Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515892 - Role EvmRole-user_limited_self_service does not allow login to self service
Summary: Role EvmRole-user_limited_self_service does not allow login to self service
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - Service
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: GA
: 5.10.0
Assignee: Ohad Levy
QA Contact: Dave Johnson
URL:
Whiteboard: testathon
: 1518309 (view as bug list)
Depends On:
Blocks: 1517986
TreeView+ depends on / blocked
 
Reported: 2017-11-21 14:50 UTC by John Hardy
Modified: 2018-06-21 20:35 UTC (History)
7 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1517986 (view as bug list)
Environment:
Last Closed: 2018-06-21 20:35:49 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)
login screen (deleted)
2017-11-21 14:50 UTC, John Hardy
no flags Details
service UI not enabled in rbac by default (deleted)
2017-11-21 14:51 UTC, John Hardy
no flags Details

Description John Hardy 2017-11-21 14:50:11 UTC
Created attachment 1356759 [details]
login screen

Role  EvmRole-user_limited_self_service does not allow login to self service

See attached screen shots, the RBAC for this role does not include Self Service.

Comment 2 John Hardy 2017-11-21 14:51:11 UTC
Created attachment 1356760 [details]
service UI not enabled in rbac by default

Comment 3 Chris Kacerguis 2017-11-21 15:03:43 UTC
Hi John - What version is this?  Is it recent?  I know this was an issue, and we recently fixed this, so I'm just wondering if you have a version with the fix?

(the fix was back ported 4 days ago)

https://github.com/ManageIQ/manageiq/pull/16329

Comment 5 Chris Kacerguis 2017-11-28 15:41:02 UTC
*** Bug 1518309 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.