Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515845 - Resume Behaviour doesn't match settings if storage is unblocked immediately after Pause state.
Summary: Resume Behaviour doesn't match settings if storage is unblocked immediately a...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: 4.2.0
Hardware: x86_64
OS: Linux
unspecified
high vote
Target Milestone: ---
: ---
Assignee: Michal Skrivanek
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-21 13:20 UTC by Polina
Modified: 2018-01-24 07:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-23 08:58:14 UTC
oVirt Team: Virt


Attachments (Terms of Use)
In engine log attached you can see in line 18037 "VM has been paused due to storage I/O problem". and then in line 18042 'Paused' --> 'Up' instead of 'KILL' (deleted)
2017-11-21 13:20 UTC, Polina
no flags Details

Description Polina 2017-11-21 13:20:47 UTC
Created attachment 1356676 [details]
In engine log attached you can see in line 18037 "VM has been paused due to storage I/O problem". and then in line 18042 'Paused' --> 'Up' instead of 'KILL'

Description of problem:


Version-Release number of selected component (if applicable):
ovirt-engine-setup-plugin-ovirt-engine-4.2.0-0.0.master.20171119135709

How reproducible:
100 %

Steps to Reproduce:
1.Create VM with iscsi disk, open High Available tab, don't check HA, set Resume Behaviour = KILL.
2. block iscsi storage with command iptables -I INPUT -s 10.35.146.129 -j DROP.
3. as soon as you see in engine.log the message "VM vm_glance_templ_scsi has been paused due to storage I/O problem.", unblock the storage

Actual results:
as the storage is back the VM goes back to Up instead of settings in Resume Behaviour tab. It is true for both settings 'KILL' and 'Stay Paused'.

Expected results:
After the storage is back I expect the VM to behave according to Resume Behaviour settings KILL or Stay Paused.

Additional info:
engine log attached

Comment 1 Michal Skrivanek 2017-11-22 05:35:29 UTC
How is this case different from bug 1515750?

Comment 2 Tomas Jelinek 2017-11-22 07:54:21 UTC
also, how long has the storage been blocked?

Comment 3 Tomas Jelinek 2017-11-23 08:58:14 UTC
I had a better look again at this report.
The thing is that this is not a bug. It will not kill the VM immediately to avoid killing VMs when there are only short storage unavailabilities.

Hence, closing as not a bug.


Note You need to log in before you can comment on or make changes to this bug.