Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515822 - Upgrade 11->12 failes with: "Could not find the requested service openstack-swift-object-expirer: host"
Summary: Upgrade 11->12 failes with: "Could not find the requested service openstack-s...
Keywords:
Status: CLOSED DUPLICATE of bug 1470041
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 12.0 (Pike)
Assignee: Marios Andreou
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-21 12:33 UTC by Udi
Modified: 2017-11-23 08:02 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-23 08:02:01 UTC
Target Upstream Version:


Attachments (Terms of Use)
Full error message (deleted)
2017-11-21 12:33 UTC, Udi
no flags Details


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 521917 None None None 2017-11-23 08:02:01 UTC

Description Udi 2017-11-21 12:33:25 UTC
Created attachment 1356666 [details]
Full error message

Description of problem:
I had an undercloud and overcloud deployed in a virtual environment with OSP11. The overcloud was deployed with the GUI and had 3 controllers, 1 compute and 3 ceph nodes. The only optional environment file that was used in the deployment was storage-environment.yaml.

The upgrade of the undercloud went smoothly, but the upgrade of the overcloud failed. See attached text file with the full error message from the failure. The command that was used to upgrade the overcloud:

openstack overcloud deploy --templates \
 -e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml \
 -e /usr/share/openstack-tripleo-heat-templates/environments/major-upgrade-composable-steps-docker.yaml \
 -e $HOME/docker-osp12.yaml \
 -e $HOME/init-repo.yaml \
 -e $HOME/remove-packages.yaml 

I tried with UpgradeRemoveUnusedPackages set to "true" initially, and then tried setting it to "false" and still hit the same error.


Version-Release number of selected component (if applicable):
openstack-tripleo-common-7.6.3-0.20171028055750.el7ost.noarch
openstack-tripleo-heat-templates-7.0.3-0.20171024200825.el7ost.noarch


How reproducible:
unknown


Steps to Reproduce:
1. Deploy OSP11 from the GUI: 3 controllers, 3 ceph and 1 compute.
2. Upgrade the undercloud.
3. Upgrade the overcloud using the command given in the description.


Actual results:
"Could not find the requested service openstack-swift-object-expirer: host"


Additional info:
The same error also repeats for openstack-ceilometer-collector service. See attached file for the full error.

Comment 1 Marios Andreou 2017-11-21 14:46:03 UTC
looks like duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1470041#c4

Comment 2 Marios Andreou 2017-11-23 08:02:01 UTC

*** This bug has been marked as a duplicate of bug 1470041 ***


Note You need to log in before you can comment on or make changes to this bug.