Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515801 - OSP11 -> OSP12 upgrade: glance_api container is in Restarting state post upgrade on environment with NFS backend for Glance
Summary: OSP11 -> OSP12 upgrade: glance_api container is in Restarting state post upgr...
Keywords:
Status: CLOSED DUPLICATE of bug 1514059
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 12.0 (Pike)
Assignee: Angus Thomas
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-21 12:18 UTC by Marius Cornea
Modified: 2017-11-21 14:32 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-21 14:32:32 UTC


Attachments (Terms of Use)

Description Marius Cornea 2017-11-21 12:18:45 UTC
Description of problem:
OSP11 -> OSP12 upgrade: glance_api container is in Restarting state post upgrade on environment with NFS backend for Glance.

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-7.0.3-9.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy OSP11 with NFS backend for Glance
2. Upgrade to OSP12
3. Check containers status via docker ps on controller nodes

Actual results:
[heat-admin@controller-r00-00 ~]$ sudo docker ps | grep glance_api
4e4a1b9cc852        docker-registry.engineering.redhat.com/rhosp12/openstack-glance-api-docker:20171116.1                "kolla_start"            15 hours ago        Restarting (1) 21 minutes ago                       glance_api

[heat-admin@controller-r01-01 ~]$ sudo docker ps | grep glance_api
53dc8da9d7c9        docker-registry.engineering.redhat.com/rhosp12/openstack-glance-api-docker:20171116.1                "kolla_start"            15 hours ago        Restarting (1) About an hour ago                       glance_api

s[heat-admin@controller-r02-02 ~]$ sudo docker ps | grep glance_api
2310f78a8cc1        docker-registry.engineering.redhat.com/rhosp12/openstack-glance-api-docker:20171116.1                "kolla_start"            15 hours ago        Restarting (1) About an hour ago                       glance_api


Expected results:
glance_api container is running and Glance api services is available.

Additional info:
[root@controller-r02-02 ~]# docker logs -f glance_api
ERROR:__main__:MissingRequiredSource: /var/lib/kolla/config_files/src/* file is not found
INFO:__main__:Loading config file at /var/lib/kolla/config_files/config.json
INFO:__main__:Validating config file
INFO:__main__:Kolla config strategy set to: COPY_ALWAYS
INFO:__main__:Copying service configuration files
ERROR:__main__:MissingRequiredSource: /var/lib/kolla/config_files/src/* file is not found

/var/lib/config-data/puppet-generated/glance_api is empty:

[root@controller-r02-02 ~]# ls /var/lib/config-data/puppet-generated/glance_api
[root@controller-r02-02 ~]# 

Attaching the sosreports from controller nodes.

Comment 2 Marius Cornea 2017-11-21 14:32:32 UTC

*** This bug has been marked as a duplicate of bug 1514059 ***


Note You need to log in before you can comment on or make changes to this bug.