Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515775 - Perform SSA on container image cause Task view get error 500 Internal Server Error
Summary: Perform SSA on container image cause Task view get error 500 Internal Server...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: SmartState Analysis
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.10.0
Assignee: Martin Povolny
QA Contact: brahmani
URL:
Whiteboard:
: 1516483 (view as bug list)
Depends On:
Blocks: 1517916
TreeView+ depends on / blocked
 
Reported: 2017-11-21 11:28 UTC by brahmani
Modified: 2018-11-27 10:31 UTC (History)
7 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1517916 (view as bug list)
Environment:
Last Closed: 2018-06-21 20:34:17 UTC
Category: Bug
Cloudforms Team: Container Management


Attachments (Terms of Use)
tasks error (deleted)
2017-11-21 11:28 UTC, brahmani
no flags Details

Description brahmani 2017-11-21 11:28:21 UTC
Created attachment 1356609 [details]
tasks error

Description of problem:
Just after perform SSA on Container Image , when i get to tasks view , i get the attach error message: 500 Internal Server Error.
I was able to get to task view before i perform SSA.


Version-Release number of selected component (if applicable):
5.9.0.9.20171115202245_7429f75

How reproducible:
100%

Steps to Reproduce:
1.compute -->containers--> Container Images
2.from table click on one of the images to get to Image summary 
3.Configuration --> Perform SmartState Analysis
4.EVM--> tasks

Actual results:
500 Internal Server Error

Expected results:
get the tasks view.

Additional info:

Comment 2 Erez Freiberger 2017-11-22 13:57:30 UTC
This seems to be introduced by [1] https://github.com/ManageIQ/manageiq-ui-classic/pull/2712

After [1], tasks for scanning ManageIQ::Providers::Openshift::ContainerManager::ContainerImage will crush the task view because there is no controller for that class and it should use the ContainerImage controller.

The problem originates from: https://github.com/ManageIQ/manageiq-ui-classic/blob/master/app/controllers/application_controller.rb#L1097-L1098

`underscore_class = row.data["job.target_class"].underscore` will get `"manageiq/providers/openshift/container_manager/container_image"` and it is not clear to me how to redirect this to `"container_image"`

Comment 4 Martin Povolny 2017-11-23 10:21:57 UTC
Probably related also to:

https://bugzilla.redhat.com/show_bug.cgi?id=1516483

Yes, seems we have no idea what are all the possibilitie here. No specs to fail :-(

Can I get a backtrace for this?

p.s. Please, include stracktraces if all future BZ that deal with a 500.

Comment 9 Martin Povolny 2017-11-23 14:06:40 UTC
*** Bug 1516483 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.