Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515768 - PrestoDB translator - Convert to float not pushed correctly
Summary: PrestoDB translator - Convert to float not pushed correctly
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Teiid, Documentation
Version: 6.4.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 6.4.0
Assignee: David Le Sage
QA Contact: Jan Stastny
URL:
Whiteboard:
: 1533482 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-21 11:05 UTC by Andrej Smigala
Modified: 2018-02-01 08:17 UTC (History)
8 users (show)

Doc Type: If docs needed, set a value
Doc Text:
If you attempt to convert a value to float in a PrestoDB query, you will encounter a exception. This only happens if convert is one of the criteria. This issue is caused by the fact that PrestoDB support was developed before the database lacked a single float type. To work around this issue, aboid using float in conjunction with convert in your PrestoDB queries.
Clone Of:
Environment:
Last Closed: 2018-02-01 08:17:03 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIID-5168 Major Resolved PrestoDB translator - Convert to float not pushed correctly 2018-06-05 12:38:45 UTC

Description Andrej Smigala 2017-11-21 11:05:07 UTC
Running query such as

SELECT StringKey, (convert(StringKey, float)+3)  FROM BQT1.SmallA

Fails with an exception: line 1:45: '+' cannot be applied to varchar(10), double


See jira for more details

Comment 4 David Le Sage 2017-11-27 23:09:03 UTC
Documented as known issue in release notes errata.

Comment 5 Jan Stastny 2018-01-15 14:16:18 UTC
*** Bug 1533482 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.