Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1515753 - [RFE] tag control dialog item not dynamics
Summary: [RFE] tag control dialog item not dynamics
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: cfme-future
Assignee: Greg McCullough
QA Contact: Jadh
URL:
Whiteboard: testathon
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-21 10:21 UTC by Cyril Coupel
Modified: 2018-08-08 13:13 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-08 13:13:28 UTC
Category: ---
Cloudforms Team: CFME Core


Attachments (Terms of Use)
drop down list with dynamics option (deleted)
2017-11-21 15:30 UTC, Cyril Coupel
no flags Details
tag control with no dynamics control (deleted)
2017-11-21 15:31 UTC, Cyril Coupel
no flags Details

Description Cyril Coupel 2017-11-21 10:21:59 UTC
Description of problem:
attributes of a tag control can not be dynamics, such as visibility, default value or category

Version-Release number of selected component (if applicable):


How reproducible:
every time

Steps to Reproduce:



Actual results:


Expected results:
For example, I want to ba able to hide or show the field tag control according to the value of an other field, and if it is hidden, force the selected value according to an other field

Additional info:

Comment 2 Chris Kacerguis 2017-11-21 14:23:55 UTC
Hi!

Could you please attach a screenshot or video demoing what is going on?

Thanks!

Comment 3 Cyril Coupel 2017-11-21 14:27:09 UTC
That is easy: there is no dynamic control availlable for this item. a screenshot wil just show you that there is no dynamic switch when designing the dialog.

Comment 4 Chris Kacerguis 2017-11-21 14:36:06 UTC
Hi Cyril,

I wasn't sure what UI this was referring to (based on the description I wasn't sure) so the Screenshot was to help me figure that out.  That said, you said "a screenshot wil just show you that there is no dynamic switch when designing the dialog" so that is no something the SUI can do, so that indicates this is an OPS - UI issue.  So, I'll send the ticket there.

Have a good one!

Chris

Comment 5 Cyril Coupel 2017-11-21 15:30:32 UTC
Created attachment 1356790 [details]
drop down list with dynamics option

Comment 6 Cyril Coupel 2017-11-21 15:31:03 UTC
Created attachment 1356791 [details]
tag control with no dynamics control

Comment 7 Dave Johnson 2017-11-21 20:42:49 UTC
Ruslana, can you reproduce this and make sure we have scenarios around it assuming this is in your FA.

Comment 8 Dave Johnson 2017-11-21 20:43:52 UTC
Ruslana, also, is this a regression, was it working in 5.8.1 and/or 5.8.2

Comment 9 Greg McCullough 2017-11-21 21:28:27 UTC
This is an enhancement request.  We have never supported default values or setting the category at runtime.  Since the default value cannot be specified it means the user must select an item so visibility has a limited use case.

Comment 14 Greg McCullough 2018-03-09 13:23:11 UTC
The class for category and tag entries is exposed through the classification model here: https://github.com/ManageIQ/manageiq-automation_engine/blob/master/lib/miq_automation_engine/service_models/miq_ae_service_classification.rb

This would allow a standard drop-down to expose tagging data.

For example:
category = $evm.vmdb(:classification).find_by_name("location")
category.name
=> "location"

category.entries.first.name
=> "ny"

category.entries.first.description
=> "New York"

category.entries.first.to_tag
=> "/managed/location/ny"


Note You need to log in before you can comment on or make changes to this bug.